Microsoft GP through windows 2003 terminal server.

While login GP through windws 2003 termail server ,  previously login user id is apperaing as
default iuser-id in  login window.  

Window name "Welcome to Microsfot Great plains..window"
backer-mAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin OwensITIL Problem ManagerCommented:
backer-m,
Would you mind restating your question?  I am not exactly sure what you are needing.
Cheers,
Justin
0
backer-mAuthor Commented:
GP = Great Plains application.
------------------------------------------------------------------------------------------------------

Our users connected GP  Windows terminal server.

There is no issue on windows server login.

We have  made setup   when user login it automatically goes to GP.
(In user properties "Environment" - " Start program"  - c://.............etc)

For an example, after a  user "A" login GP ,

when the user "B" login to GP user id shows "A",
I
(It is not a big issue. He can change it.)

 why the user "A" appears.


Both the users have separate windows login and also separate GP login.

It happens only in GP login. Not windows login.
0
Justin OwensITIL Problem ManagerCommented:
That is a Great Plains issue with older versions.  They show the last login from that machine, not from that profile.  I am guessing that you are not running the most current version of Great Plains.
Justin
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

backer-mAuthor Commented:
To Great Plains experts : -

Please confirm whether this is the Great Plains older version issue. Our versions is GP 8.00

0
Steve EndowMicrosoft MVP - Dynamics GPCommented:
Hi,

This is a "feature" of GP.  It retains the last GP login and displays it as the default user ID, with the assumption that GP is installed on a user's PC and they will be the one logging in each day.  This is not an issue with older vs. newer versions of GP.

This is a common complaint among people who use Terminal Services and do not want the last user ID to be displayed.

There are two solutions, both of which are discussed in KB articles on Customer Source.

1) Write a VB script on the login window that will 'blank out' the user ID field when the window appears

2) Remove the last user from the Dex.ini file on the Terminal Server and make the Dex.ini file read only

I would recommend searching Customer Source.  If you can't find the articles that cover the options above, let me know and I will track them down for you.

Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified Professional



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
backer-mAuthor Commented:
Mr Steve Endow,

Thanks for the soloution.

Can you please track down from the customer source and let me know.
0
Steve EndowMicrosoft MVP - Dynamics GPCommented:
Hi,

The VBA option is discussed in KB Article 859129, "Blank User ID in Great Plains".

I'm not able to find an article discussing the Dex.ini option--that might have come from a support case that I submitted for the issue.

Here's the abridged version:

1. Locate and open the Dex.ini file in the Dynamics application directory on the terminal server
2. Find the SQLLastUser=xxxxx line and delete the user ID value ("SQLLastUser=")
3. Save the Dex.ini
4. Make the file Read Only

The downside to this approach is that any user preferences or setttings that a GP user may need or want to change and have saved to the Dex.ini will obviously not be saved.  This may not be an issue for your environment, but just keep it in mind in case a user complains about a setting or preference going away, or users with different screen resolutions have issues with the GP window location and size (since those settings are stored in Dex.ini).


Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified Professional



0
backer-mAuthor Commented:
Thanks. I changed dex.ini. It is  working fine
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Tax / Financial Software

From novice to tech pro — start learning today.