[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 668
  • Last Modified:

HTTP Post Returns 404

I have set up a webserver running server 2008 x64.  Everything seems to be working correctly however I cannot post a file using HTTP Post.  I can navigate to the post url in a web browser and it displays (500, 04, No data received) just like the other webserver.  Yet whenever I try to post to the server it returns:  

HTTP Post Error: 404 Not Found
HTTP Post Error Detail:
 HTTP/1.1 404 Not Found
Server: Microsoft-IIS/7.0

The IIS log reads: POST /ics/post.dis - 80 - 10.10.2.60 Example+Poster 404 13 0 46

I know the software is configured correctly, and the only difference between the two servers is that the working one is server 2003.  IIS7 is considerably different is there possibly a setting that I am missing?
0
HelpDeskatTMC
Asked:
HelpDeskatTMC
3 Solutions
 
Bryan ButlerCommented:
Seems wierd.  Is there other entries in the log?  I think you will have to troubleshoot it.  Here's some links that might help with that:

http://stackoverflow.com/questions/705229/diagnosing-404-errors-on-iis-7-and-asp-net-mvc
http://mvolo.com/blogs/serverside/archive/2007/07/26/Troubleshoot-IIS7-errors-like-a-pro.aspx
0
 
mrcoffee365Commented:
Did you allow POST in the list of allowed actions for the .dis file type?  See the tab in the IIS Manager app Properties for your Web site (or the Default Web site).
0
 
SWomannCommented:
You should also check UAC and NTFS-Security Settings.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now