Win XP Pro Clients Losing Mapped Drives to Win 2003 Domain Server

I have a problem that sounds similar to ID 25132513 but we are not using external DNS servers.

In our environment we have two Win 2003 servers and about 40 PC clients.  Most of the clients are still running Win2K (it is a manufacturing facility) but 5 PCs are running Windows XP Pro.  Both  servers and all clients are current with SPs and other updates.  We are experiencing a problem with just the WinXP clients where after running for most of the day (generally about 9 hours), we lose our connections to the mapped network drives (connected via a login batch script) - the error we get is:  "An error occurred while reconnecting s: to \\{server_ip}\apps
Microsoft window network: the local device name is already in use. the connection has not be restored."  The affected PCs still have Internet connectivity but cannot not access the network drives until they are re-booted.  Two of the affected computers are laptops with dynamic IPs, the other three have static IPs.  The Win2K computers can run for weeks and never have a problem - it is just affecting our XP computers.  Recently it has gotten much worse on one of the computers where it can boot up in the morning and not be able to connect and might require 3-4 re-boots before the user can connect.

Both servers and most clients were set up prior to my joining the company so I do not know the specifics of the configuration.  I am a software developer of many years but have no real networking experience other that what I have taught myself so please let me know what other information you might need to be able to help me solve this problem.  Thanks!






laptop.txt
laserati.txt
ffreemanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin OwensITIL Problem ManagerCommented:
Can you include the code from your batch script?
0
ffreemanAuthor Commented:
I have included three different logon scripts in the attachment.  Each department has slightly different scripts and this list includes all that are being used by the WinXP computers.
Log-On-Scripts.txt
0
spiderwilk007Commented:
You could try mapping the drives from the user profile(s) and discard the batch script. Under my computer, "map network drive" make sure "reconnect at login" is checked then save your mapped drive.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Justin OwensITIL Problem ManagerCommented:
Try changing it to match the code below:
custserv.bat

NET TIME \\server1 /set /y
NET USE I: \DELETE
NET USE I: \\SERVER1\IMPORT /PERSISTENT:YES
NET USE L: \DELETE
NET USE L: \\SERVER1\LOGO /PERSISTENT:YES
NET USE X: \DELETE
NET USE X: \\SERVER1\SOSET /PERSISTENT:YES
NET USE R: \DELETE
NET USE R: \\SERVER1\CUSTSERV /PERSISTENT:YES

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
antimacosCommented:
Have you tried adding a disconnect in your batch file? Disconnect then reconnect? Also may check out firewall on XP machine. Try disabling it and test.

net use s: /delete
net use s: \\servername\apps /persistent:yes

http://ss64.com/nt/net_use.html
0
Darius GhassemCommented:
Add the net use x: /delete for every drive letter before allowing them to reconnect

http://support.microsoft.com/kb/890413
0
ffreemanAuthor Commented:
I will try changing the batch files to disconnect each drive before re-connecting but after reading the MS KB entry, do not understand why it would typically work fine for 8-9 hours and then lose the connection (we are not using any different connection types to connect to the file server).  I will test on my laptop and leave on overnight and should have some results in the morning.  
0
Justin OwensITIL Problem ManagerCommented:
The /persistent switch causes XP to reconnect if the network connection is dropped.  Your /yes doesn't do the same thing as /persistent:yes.
0
antimacosCommented:
Something that came to mind is that on laptops there is a power save setting that has to be corrected. Below are the  REGkeys I have found to cause problems. Changing the values to "0" turn the power save off. Now your computer will not have all 0001 to 0022 devices, but  change the setting for the ones you have. Reboot and see if that fixes the issue...   "Disclaimer: Please back up the registry before making any changes. The one time you don't is the one time you'll need to restore it."

This worked for us in an environment where we had 100+ computers showing Domain Not Found. Attached is code to change it.



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0001]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0002]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0003]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0004]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0005]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0006]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0007]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0008]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0009]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0010]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0011]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0012]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0013]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0014]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0015]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0016]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0017]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0018]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0019]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0020]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0021]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\0022]
"PnPCapabilities"=dword:00000038
"PowerSaveMode"="0"

Open in new window

0
ffreemanAuthor Commented:
My WiFi adapter currently has a value of 0x00000030 (48) and my Intel NIC has a value of 0x00000020 (32).  If the disconnect / reconnect fix above does not work, I will give this a try but am also having the problems on several desktop computers (My XP boxes consist of 2 laptops & 3 desktops that are all having the problem)
0
Darius GhassemCommented:
Anything to look at is the Binding order make sure that the Network Card being used is at a higher binding order. Go to Network Connections click Advance menu the Advanced settings.
0
ffreemanAuthor Commented:
After changing my login script to disconnect and reconnect with the persistent switch, I left both my laptop and one of my production desktops on over night.  This morning when I checked both of them, they still had internet access but none of the mapped network drives were accessible.  The error I got stated that "X:\ is not accessible.  The system detected a possible attempt to compromise security.  Please ensure that you can contact the server that authenticated you."
0
antimacosCommented:
Microsoft support pages for that error:
http://support.microsoft.com/kb/938457

RESOLUTION
To resolve this issue, reset the trust relationship. To do this,
follow these steps: 1. At a command prompt, type c:\>netdom trust
domain on which the trust is created /domain:the parent, child, or
tree root domain being trusted /reset, and then press ENTER.

Important You must use the fully qualified domain names (FQDNs) in
this command.

After you run this command, you receive the following message:
Resetting the trust passwords between domain on which the trust is
created and the parent, child, or tree root domain being trusted The
trust between domain on which the trust is created and the parent,
child, or tree root domain being trusted has been successfully reset
and verified The command completed successfully.
2. Obtain the domain on which the trust is created domain controller
object GUID. To do this, follow these steps: a. At the command
prompt, type repadmin /showreps mydc1, and then press ENTER, where
mydc1 is the computer name of the domain on which the trust is created
domain controller.
b. Note the objectGUID line at the top of the output. The object GUID
looks similar to the following object GUID:
a6999e16-99b5-432f-9bc5-3eecf5dc192f

3. Make sure that replication occurs correctly between the two
replication partners. To do this, run the c:\repadmin /sync
cn=configuration,dc=mydomain,dc=com mydc1objectGUID command at a
command prompt by using the object GUID that you noted in step 2. You
receive output that is similar to the following output:
Sync from a6999e16-99b5-432f-9bc5-3eecf5dc192f to mydc1 completed
successfully.


0
ffreemanAuthor Commented:
The trust relationship resolution is above my networking pay grade but here is what I have been able to determine:

I tried running the netdom command but no such program was found on my server.  I also did a file search for netdom* and got no results.  I then went into the Active Directory Domain & Trusts.  We only have 1 domain listed, rssco.local, and there are no trusts associated with it.  (Both servers are in the same domain and everything else is just a client machine)

While I was there, I also looked at the Raise Domain Functional Level and we are still set at the default Windows 2000 Mixed level.
0
Darius GhassemCommented:
You have to install the support tools to reset the secure channel password with  netdom.
0
ffreemanAuthor Commented:
I have the support tools installed on both of my servers (both are Win 2003 Server SP2 Enterprise edition).  I have read the MS support page link you provided and need some clarification.  The support link says that you get the error message when you try to include security settings for a user from different domain in a local domain folder.  But in our case, we only have a single domain.  I also looked at the netdom help and it says that it allows you to set up trust relationships between two domains.  Again, we only have one domain - what would I specify for the trust domain and the domain being trusted?
0
Justin OwensITIL Problem ManagerCommented:
Trust relationships generally only play into the issue if multiple domains are in question.  In this case, it is most likely NOT a trust relationship issue.  If it was one, you would never connect to begin with.  When you did your test in post 30023034, did you also change the power settings as antimacos suggested in post 29948340?
Justin
0
ffreemanAuthor Commented:
Sorry for the delay - I made the changes on my laptop and everything seems to be working so I made the same changes on another laptop and a desktop.  When I came in this morning, I was still able to access the network from my laptop but the other two computers got the same "X:\ is not accessible.  The system detected a possible attempt to compromise security.  Please ensure that you can contact the server that authenticated you" error.  Both computers were able to access the Internet, just not the mapped drives.  Once they were re-booted, everything connected as normal.
0
Darius GhassemCommented:
Netdom allows you to reset the secure channel password as well. Trust are actually not just domain to domain trust but there are trust setup with every domain device including computers  they have a secure channel password that is used to update and validate information between the domain devices.

http://www.windowsitpro.com/article/tips/jsi-tip-3401-how-do-i-reset-the-secure-channel-s-password-in-windows-2000-.aspx

http://support.microsoft.com/kb/175024
0
ffreemanAuthor Commented:
The links provided apply to WinNT and Win2K.  None of my Win2K computers are experiencing the problem - only my WinXP Pro computers.  That said, if I do the reset, it says that the computer will have to re-join the domain.  Will my user information be saved or will I have to reconfigure everything once I re-join the domain?   i.e. in my Documents and Settings directory, I have a user directory pam.rssco that contains all her configuration information.  Will it use this same "user" and directory or will it create a new user directory?

One other thing to note - I noticed today that when I re-booted the laptop, that I was unable to connect to the mapped drives (same compromise security error) immediately upon startup (as opposed to a timing out issue).  I re-booted again and was able to connect but when I checked with another WinXP user that is having the problem, she indicated that she also has this happen sometimes on booting up and has to re-boot again (sometimes 2 or 3 times) before she can access the network drives.
0
Darius GhassemCommented:
The links and tools are still available in 2003 and 2008 that makes no difference. Once you join back to the domain all user profiles will stay the same nothing will change.

Here is another thing to check. If users are plugging in there laptops into the LAN then you need to check to make sure the the LAN NIC is set to a higher priority in the Binding order. Go into Network Connections then click Advance Menu and select Advance Settings.
0
ffreemanAuthor Commented:
I did a domain reset from my server for two of the affected computers (1 laptop, 1 desktop).  I re-booted the laptop and was able to connect to the domain and left it running last night.  When I came in this morning, I still had access to the network shares and will monitor it during the day but it looks good for this computer.  The desktop was a different story.  After re-booting the computer, I got the same security error as soon as I tried to access the shared drive.  I re-booted it three times in a row and got the error each time.  This morning my user started up the desktop and was able to connect to the shared drives but it appears that we are still getting the error on this unit.
0
Justin OwensITIL Problem ManagerCommented:
Are the two workstations in the same OU and have the same GPOs applied to them?
0
ffreemanAuthor Commented:
I was not the one that set them up but from what I can see, yes, they are both in the same OU with the same GPOs applied to them.  The only thing I noticed when looking at the computer properties (which may be nothing), is that the domain name in the DNS name of the problem computer is all caps (RSSCO) where as all the other computers has the entry in lower case.  (e.g. Linda2.RSSCO.local vs Pamu.rssco.local)
0
Justin OwensITIL Problem ManagerCommented:
Capitalization should not matter.  You can tell OU and GPOs with difinity if you do a GPRESULT from the command prompt on each machine.
0
ffreemanAuthor Commented:
I ran GPRESULT on both computers and definitely see some differences.  I am attaching both files.  The file pam.txt is from the laptop that IS working.  The file linda.txt is from the desktop that IS NOT working.
pam.txt
LINDA.TXT
0
Justin OwensITIL Problem ManagerCommented:
The LINDA computer has no GPOs applied to it.  I would get it moved into the correct OU, as that may make a difference.  Once you get the GPOs the same, we can look through it/them if it still doesn't work.
0
ffreemanAuthor Commented:
Do I simply remove her computer from the domain and then re-add it (keeping her existing domain user)?
0
Justin OwensITIL Problem ManagerCommented:
No.... In ADUC (Active Directory Users and Computers), find the computer.  If you just joined it to the domain, it is probably in the "Computers" OU.  Move it to the correct OU.  Once moved, do a "GPUPDATE /force" to make sure it is getting the correct GPOs applied to it.
0
ffreemanAuthor Commented:
If I am interpreting it correctly, we only have a single root level OU and all the computers are in it.  I have attached a screen shot showing the listing.  Please correct if I am wrong.  I did try the GPUPDATE /force command but the GPRESULTs for Linda's computer are the same.
ScreenShot.jpg
0
Justin OwensITIL Problem ManagerCommented:
I see PAMU in that list, but I don't see LINDAB, which is the second computer.  Can you do a search for that computer and make sure that it is in there?
0
ffreemanAuthor Commented:
Looking at Linda's computer, the computer name is listed as LINDAB.  Looking at the active directory, there is no computer entry for LINDAB but there is one for LINDA2.
Linda-computer.jpg
Linda-AD1.jpg
Linda-AD2.jpg
0
Justin OwensITIL Problem ManagerCommented:
It looks like that computer is not correctly joined to the domain.  I would remove it, wait for replication (if you have more than one DC) and then rejoin.
0
ffreemanAuthor Commented:
It appeared that I had two separate problems but both have been fully resolved now.  Thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.