Newly Moved Mailbox from 2003 can't receive mail

Introduced one 2010 exchange server (hub, mailbox, CAS) that will  replace a front end, back end 2003 environment.  We utilize a smarthost ironport gateway that email goes through, in and out.  When I move a mailbox to the 2010 server it will send mail internal and external but won't recieve mail, internal or external.

LVL 1
tfgeorgeAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ThaVWManConnect With a Mentor Commented:
Ok... you need to create a smtp connector on your 2003 server first, that covers all of your mail, and sends it to your ironport system.  Then you can take out the smarthost in the default smtp server settings and all should be fine.  MS best practices does not want you to be putting that setting in the smtp server itself.
0
 
ThaVWManCommented:
DId you setup and configure the receive connectors on your new 2010 system to allow connections?  Do you have your ironport still sending mail to the 2003 system first?
0
 
tfgeorgeAuthor Commented:
Ironport still sends to the 2003 first.  If by receive connector you mean send connector, YES.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
tfgeorgeAuthor Commented:
ThaVWMan- sorry for the 2nd part of the last post.  Yes there is a default and a client recieve connector that was automatically created when the server was installed.
0
 
ThaVWManCommented:
If you log into the exchange 2003 management console, do you see the connectors from the 2003 to the 2010 server in both Admin Groups?
0
 
tfgeorgeAuthor Commented:
Yes.  They are in both admin groups.  
0
 
ThaVWManCommented:
Have you tried the BPA or mail flow troubleshooter to see if it can figure out where the breakdown is?  Given that you can send from the 2010 box, but nothing is allowed back in, it sounds like we have a permissions problem on one of the inbound connectors... either it is locked down by IP, or by user rights......
0
 
ThaVWManCommented:
If you look at the queue manager on the 2003 box, do you see all of the emails you are missing on the 2010 side sitting there?  Any messages from the queue as to what is going on?
0
 
tfgeorgeAuthor Commented:
Nothing came up in the BPA.
0
 
tfgeorgeAuthor Commented:
When I go to the 2003 box ESM under Tools-Status it says the new 2010 server is "unreachable"
0
 
ThaVWManCommented:
Are you able to ping the new server by name from the 2003 system?  Have you verified that DNS is set up and working correctly?  Make sure the exchange 2003 box is not set to use some external DNS server for lookups.
0
 
tfgeorgeAuthor Commented:
The messages that I tried to receive on the new 2010 mailbox are stuck in the routing group connector.  I can see them from the 2003 ESM queue.
0
 
tfgeorgeAuthor Commented:
Can ping the 2010 server by name from the 2003.  The DNS is configured properly with internal DNS set to our domain controllers/DNS servers.
0
 
ThaVWManCommented:
When you click on the queue in the ESM, what does it state at the bottom as the status or last result?
0
 
tfgeorgeAuthor Commented:
"Exchange System Manager failed to retrieve queues for the SMTP Virtual Server (error code = 0x800706D9).  Check the event log and verify that the required services are running."
0
 
tfgeorgeAuthor Commented:
Does the 2003 box need to be rebooted since the install of 2010?
0
 
ThaVWManCommented:
its possible... it wouldnt hurt if you can do that.  You could just retry restarting the SMTP service on the 2003 box first.
0
 
tfgeorgeAuthor Commented:
the 2 other exchange services that are disabled are the site replication service and pop
0
 
tfgeorgeAuthor Commented:
gonna have to wait till 5pm central time to restart smtp or reboot
0
 
ThaVWManCommented:
Your users would not notice the SMTP service being rebooted.... but with only 5 mins to go....   Those services are fine to be disabled, they are not causing our issue.
0
 
tfgeorgeAuthor Commented:
restarted the SMTP service on the 2003 box...still no go
0
 
ThaVWManCommented:
How big is this AD domain?  Is all of the sites and services items set up correctly?  I am not sure if it matters in this case or not, but I believe that Exchange 2007 and 2010 both use sites and services now for email routing.... would be worth it just to check it out.  Make sure that all of the subnets are defined, and that the servers are assigned to the correct ones.

Check out this link as well:

http://technet.microsoft.com/en-us/library/dd638103.aspx
0
 
Vishal BreedProgram ManagerCommented:
check the properties (mainly email addresses tab) of new mailbox created in Exchange 2010 with mailbox moved from exchange 2003. Looks to me, Exchange 2003 mailbox is not getting exchange 2010 attributes!!!

Please mention the error code you see in NDR (non delibery report) email  
0
 
tfgeorgeAuthor Commented:
Vishal- checked the E-Mail tab on the mailbox properties.  The only differece is that the 2003 mailboxes have a X500 entry and a newly created mailbox on the 2010 server does not.  As for smtp it is the same and X400 is the same.
0
 
Vishal BreedProgram ManagerCommented:
Looks really straight forward, could you please paste NDR error here?
0
 
tfgeorgeAuthor Commented:
We use a smart host.  Internal email is going to the smart host when it should get routed to the other internal 2010 box from the 2003 box.
0
 
tfgeorgeAuthor Commented:
Vishal -
Final-Recipient: rfc822;user@domain.com
Action: delayed
Status: 4.4.7
Will-Retry-Until: Thu, 8 Apr 2010 16:32:39 -0500
X-Display-Name:
0
 
ThaVWManCommented:
On the 2010 server, does it show that your internal domain is one of its "accepted domains"?
0
 
tfgeorgeAuthor Commented:
internal domain is listed under accepted domains with type authoritative
0
 
ThaVWManCommented:
In the 2003 ESM, under the 2003 server queues, you said things were sitting in the routing group connector.  When you highlight that connector, what does it say down at the bottom under "addtional queue information"?

Also, you may want to look at cranking up your diagnostic logging on the 2003 server.  Goto the properties of the server, and the diag log tab.  I would think we need to start by going to msexchange transport, and turning routing and smtp up to max.  See if that gives you any event logs that are helpful.
0
 
ThaVWManCommented:
Also, on the 2010 server, the receive connectors... I know you said the default ones are there, but lets try this.  I am also using a 3rd party spam filter, so we smart host all of our mail out.  Lets set up a receieve connector for that service, which will also be the connector for the 2003 server.

First off, disable the "Default %SERVERNAME%" rec connector, leaving just the client one enabled.

Then we are going to do a new receive connector, put in Ironport for the name, and leave as custom.

Leave the "all available IPv4" in the list, and then put in the FQDN for the server.

Leave the default entry for the remote network settings.  Then finish the wizard.

Go into the properites of the new connector, click on the network tab, and in the lower box put in the IP's for your 2003 exchange server, as well as for your ironport servers.

Auth tab needs to have everything checked except Externally Secured.

Permissions group tab check Anon, exchange servers, and legacy exchange servers.  Click ok, then restart the SMTP service on the 2003 box to see if it can now send.
0
 
tfgeorgeAuthor Commented:
New receive connector fails:
Error the values that you specified for the bindings and remoteIPranges parameter conflict with the settings on the Receive connector " " A receive connector must have a unique combination of local IP address, port binding, and remote IP ranges
0
 
ThaVWManCommented:
Check the Client connector and make sure that under the network tab the only port being used is 587.  Were you sure to disable the Default connector first as well?
0
 
tfgeorgeAuthor Commented:
It was the settings on the SMTP virtual server.
0
 
ThaVWManCommented:
Was the smarthost set in there instead of on a connector?  
0
 
tfgeorgeAuthor Commented:
Yes, and if I change it there it breaks my production 2003 mailflow
0
 
tfgeorgeAuthor Commented:
thanks for sticking with m vwman. ironport requires port 28 for incoming internal so the only way to do that is from the SMTP virtual server.  I'm thinking of setting up an extra smtp virtual server on a different port that could servic email flow from 2003 to 2010
0
 
ThaVWManCommented:
Yes, that would be the other option.  I would still suggest you move the smart host off of the smtp virtual server itself, and still use a smtp connector.  You would just have to SMTP virtual servers using the different ports you need, and you would set the connectors to use which ever one they needed.  Check out the link below:

http://support.microsoft.com/kb/265293

You are welcome!
0
 
tfgeorgeAuthor Commented:
Partial answer
0
All Courses

From novice to tech pro — start learning today.