IIS 7.0 (2008r2) - Change Password page setup (formally IISADMPWD)

I have a new 2008R2 server, I've installed IIS for giving some external people read access to a file share - it works great with directory browseing.  I've created the users in a seperate ou.

My only issue is I need to give the users the ability to change their passwords.  In the old days I'd just use IISADMPWD - but it's gone.  I can find tons of articles telling me it's gone, but none have links on how to do the same thing now.

If you have an article, or if it's simple and you can post it here...  (keep in mind I am an IIS dummy).

thanks
Erik
erikwhitewayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brad HoweDevOps ManagerCommented:
Give this a shot. Found it online, haven't tested it.


http://www.eggheadcafe.com/software/aspnet/35218548/iis7-and-iisadmpwd.aspx
Below is the detailed info on this:
Password change feature using IISADMPWD is NOT available on a Windows 2008
server (IIS 7.0)

- The IISADMPWD feature has been removed from IIS 7 (Windows 2008) and is no longer supported.
- The reason behind it is that password change functionality is not related to IIS. It was provided at the time when account management was not offered elsewhere.

- Since IIS 7 is a complete rewrite in terms of architecture/code as compared to its predecessors, it was decided by the product group to remove this functionality. This however has been incorporated in Exchange and ISA.

Though it is NOT supported, here is the workaround:

1. On your IIS7 (Windows 2008) server, navigate to c:\windows\system32\inetsrv and create a folder named IISADMPWD
2. Copy the files from the IISADMPWD folder from an IIS 6.0 (Windows 2003) server and paste them under the IISADMPWD folder you just created.
3. Open IIS Manager, and expand [server name] > Sites
4. Right click on default website and select Add Virtual Directory
5. Type IISADMPWD for the alias and "c:\windows\system32\inetsrv\IISADMPWD" for the physical path then click OK
6. Right click on the IISADMPWD virtual directory and select Convert to Application
7. The Add application dialog box opens, click on the select button and choose MSExchangeOWAAppPool
8. Click OK twice to return to IIS7 Manager
9. Click on IISADMPWD folder and on the right pane, click on Authentication
10. Make sure Windows Authentication is set to Enabled, click OK (The
Authentication can be changed to Basic or Anonymous as well)
11. Close IIS7 Manager
12. Restart IIS (iisreset)

You could also check KB 833734 (http://support.microsoft.com/kb/833734) if
you run into any issues after following the above steps.

Hope the information helps,

Sincerely,
Microsoft Online Partner Support
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
erikwhitewayAuthor Commented:
That didn't work - the machine I am installing on to is not an OWA machine - but Maybe I shoudl try it on that machine - I could always do a re-direct to that machine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.