Can't join XP mode to domain

Ok so we are setting up XP Mode for some clients. I have been able to join XP mode to my domain, in fact i'm logged in one now. First things first the network is on the 192.168.1.x, so naturally i try to hardcode the ip, found a spare slot (192.168.1.45) left the dns blank because i don't really need it at this time, then try to join the domain. It prompts me for credentials, i enter them, then i get an error that it can't find the network. I double check with the hose machine, same default gateway, tried entering my host machines dns, nothing. I loose internet upon changing ip (obviously). I can't ping anywhere, not the router, the host computer, nothing. I can't ping the VM. I'm really at a loss now, i had no problem with my VM here at the shop, any ideas?
LVL 2
STS-TechAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Abduljalil Abou AlzahabConnect With a Mentor Infrastructure Team Leader – Professional ServicesCommented:
1- Start -> All Programs -> Windows Virtual PC -> Virtual Machines
2- Right click on your virtual machine configuration file.  e.g. Virtual Windows XP.vmcx
3- Select Settings from the right-click menu
4- In the Virtual PC Settings dialog, select Networking on the left.
5- Change the Adapter drop down box on the right from Shared Network (NAT) to the name of your Ethernet card.
6- Press OK
7- Restart the XP VM image.
0
 
STS-TechAuthor Commented:
An added note, whenever i change the IP address to the same network as out network (192.168.1.x) i am not prompted for credentials when tring to join the domain. Instead i get the cannot find the domain controller error. If i click details, it claims the problem is within DNS, this happens both if left blank, or pointing to my DC.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
> left the dns blank because i don't really need
> it at this time, then try to join the domain.

In other words, Active Directory is not your specialty.  Active directory NEEDS DNS.  DNS is how it finds domain controllers and other network resources.  Without CORRECTLY entering DNS, you cannot join a domain.

IF you want a static IP, that's fine, but it needs to be in a network with a route to your DC's network AND it needs to use your DCs (and only your DCs) for DNS resolution.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
STS-TechAuthor Commented:
A-J : I will try

leew : You got it, not my specialty, i'm not that kinda guy, that would be my partners. It looks like i messed up my working, i apologize, i ment that at this time dns doesn't matter, because i can't even ping anywhere.
0
 
Matthew EnglandConnect With a Mentor Technology ConsultantCommented:
Verify if your VM is running on a Host Only, NAT, or Bridged network connection.

Your XP VM needs to have DNS information configured & the DNS server it's utilizing needs to be authoritative for the domain you wish to join.

Are your VM, DNS & DC all on the same network?

Dose your host server (I'm assuming this is Windows 7?) have a client firewall enabled?
0
 
STS-TechAuthor Commented:
Pacific -

At this moment i am following A-J's steps and just switched the nic from NAT to the nic card itself. The VM is rebooting now to see the results (VM through RDP is slow as hell).

Everything is all on the same network. I have already disabled the Win 7 firewall, and the kaspersky internet security we use is not set up on the machine yet for it is a test.
0
 
STS-TechAuthor Commented:
Guys -

After changing adapters i was able to ping, and just joined the domain. I did notice, although the kaspersky wasn't active yet, the client still existed, I'd immagine the firewall would be off, i closed it anyway, not sure if that had to do with it but i'll find out next reboot.

Thanks everyone!
0
All Courses

From novice to tech pro — start learning today.