Internet sharing from Macbook (Part 2)

This thread got me setup with Internet sharing from my Macbook http://www.experts-exchange.com/Apple/Operating_Systems/OS_X/Snow_Leopard_OS_10.6/Q_25736058.html.  But when I try to connect my iPhone or iPad, both connect but then can't surf.  Each tries to load a page but fails with the "Cannot open page" error.  The Macbook is able to surf fine.

For the "Share your connection from", I have my mobile modem selected, since that is how it gets its Internet connection.
brettrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nichicksCommented:
Activate the Airport on Macbook and share from there
0
brettrAuthor Commented:
I am sharing via airport.
0
nichicksCommented:
Please try this

http://www.techradar.com/news/computing/apple/how-to-share-an-internet-connection-in-os-x-658271

as long as "Share your connection from" shows your USB modem selected in the list of the sharing panel and then "To computers using" : Airport

Good luck
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Owen RubinConsultantCommented:

OK, so note that there is a difference between "Setting up a network" under the Airport menu and sharing your internet.

So, you have probably turned on Airport by setting up a network, but you did not enabled "Network Sharing" in the Sharing Preference?

TURN OFF THE NETWORK YOU CREATED in the Airport Menu and follow these steps.

1). Got to System Preferences, and select Sharing
2). CLICK, but do not select the check box for INTERNET SHARING
3). Fill in the name you want the network to be
4). Press AIRPORT OPTIONS (lower right)
5). pick a channel, select security, give it a name if you like, and add a password.
6). Press OK
7). NOW, click Internet Sharing to turn it on, and press START in the dialog that appears.

Now on your iPhone or iPad, sleect the proper network, enter the password when prompted, and see if it works now.

0
brettrAuthor Commented:
@orrubin:

Yes - i've done all of that.  The problem is that when I try to surf from the iPad for example, after a few seconds I get a can't open page error.
0
Owen RubinConsultantCommented:
Ok, will you go to the Settings on the iPad and see if you actually have a real IP address? just click the right arrow on the selected network. If it starts with 169.something, then you are not being given an IP address by the Mac.

If that is the case, delete the network and start from scratch. I have seen this fail from time to time, and best to start over and try again.

Cheers
0
brettrAuthor Commented:
The Macbook has an IP address of 75.230.15.177 in

  System Preferences > Network > Pantech Modem

The iPad has an IP address of 10.0.2.2 and router of 10.0.2.1.

Remember, the Macbook and iPad are no longer connected to the home wireless network.  What do you make of this?
0
Owen RubinConsultantCommented:
Well, this seems correct, but I need to make sure it is still set up correctly.

What this tells me is that your Macbook is connected DIRECTLY to a DSL or Cable Modem router. (Will you please go back and edit out a few of the IP address digits please. Should not broadcast that number, as it actually tells me your a Verizon customer as well!  :-)  )

The iPad should have a 10.0.2.xx address where XX is almost any number. That is OK. The router of 10.0.2.1 is the Macbook itself, which is the router for the wireless connection, so that is OK as well.  This SHOULD work!   It is possible, that the ISP is blocking the sharing of the network, but that is unlikely.

Please confirm the following:
First, I assume you have an Ethernet cable plugged into the Macbook, right? That IS the only way this works. Make sure you can browse the net on the Mac while this is all set up.
Open the SHARING preference again.
Make sure that the "Share you connection from" pop-up has "Built-In Ethernet" selected
Confirm that "To Computers Using" has Airport only selected.

Also, go into System Preferences, Security, and then select Firewall. Set to "Allow All Incoming Connections" and see if that makes a difference.

That should work. If possible, can you try connecting to the shared connection from a laptop or other Mac, or maybe a different device? See if they can see the network.

Also, you can try and "ping" the iPad. When this is all up and running, and the iPad has an address, on the Mac open a Terminal Window, and type "ping 10.0.2.xx" (without quotes, where XX is the IP address of the iPad) and see if you get a response. It should look something like this (in my case, my iPod Touch is at 10.0.2.11):

PING 10.0.2.11 (10.0.2.11): 56 data bytes
64 bytes from 10.0.2.11: icmp_seq=0 ttl=64 time=285.402 ms
64 bytes from 10.0.2.11: icmp_seq=1 ttl=64 time=206.648 ms
64 bytes from 10.0.2.11: icmp_seq=2 ttl=64 time=127.977 ms

If you get something like this:

PING 10.0.2.12 (10.0.2.12): 56 data bytes
ping: sendto: No route to host
ping: sendto: Host is down

Then either you have the IP address wrong for the iPad, or the connection is not getting through.

As one last fix, try rebooting both the iPad and the Mac and trying again.
Remember, if the Macbook is using the wireless network to get its own internet, it cannot share that same internet with the iPad. This shares Ethernet to airport wireless. Just checking all points.

Let me know.
Cheers

0
Owen RubinConsultantCommented:
There is one more thing, and I want to go over it one more time.

Make SURE that you have not turned on "Create a Network" under the Airport menu. If this has been done FIRST, when you turn on sharing, sharing will fail. You will see a connection, but it will not work.

To confirm this, turn off sharing, and make sure that the airport menu in the tool bar looks like the little 4 segment fan symbol, and NOT a triangle with what looks like a small computer inside.

if you are not sure, turn off Airport from the menu, and then turn it back on. NOW go to SHARING preference, and try setting up Internet Sharing again.

Cheers
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.