How do I stop my Mac Pcs using Safari to stop asking for authentication on my proxy server foe some websites?

How do I stop my Mac PCs using Safari to stop asking for authentication on my ISA proxy server from some websites?
gza100Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit BhatnagarTechnology Consultant - SecurityCommented:
What is your current setup on ISA? Are you using 'Authenticated User' or 'All User' on the rule which allows the clients to the Internet. Are the clients webproxy or SNAT Clients i.e. are you using the proxy settings in IE\Safari?
If the option is Authenticated Users, the Users will have to authenticate to the Server?
Please provide answers to these questions.
0
khashayar01Commented:
I forgot the exact location and I don't have a MAC in front of me to check but i believe under system preferences -> network it lets you set the proxy servers so it doesn't ask you again.
0
gza100Author Commented:
I am currently using Integrated Authentication for all users.

My clients are Web Proxy.
0
gza100Author Commented:
I have the proxy settings located in the Safari settings.

IT just is asking the users to authentication.

If the user is not a Admin user it just gives out a 407 error.
0
mccrickCommented:
This sounds similar to a problem that happens when people change their login password in a way that does not change the primary password for Keychain. I'm wondering if you set something up for a user when you were logged in as an admin with a different acct than the user. This might cause keychain to fail when the user is logged in. (just a theory)

Anyway, whether my theory is wrong or right, you might try deleting Keychain prefs.

The Keychain is supposed to remember passwords for you so that you only type them in once. When the symptom you are describing strikes Safari, my favorite way to fix this is to delete the preferences for Keychain along with the Keychain itself. This will wipe out the memorization of all  passwords for that user so you will need to know all of your passwords and put them in as requested. Keychain may have been taking care of a password that your user has forgotten. This includes email, web logins, VPN's, etc. Make sure that your user is ready for this fix when you do this. You don't want knock out the boss's keychain 10 minutes before the next  big  meeting.

When you are ready:
Delete this folder:
<HD>/User/<USER>/Library/Keychains
and delete the file:
<HD>/User/<USER>/Library/Preferences/com.apple.keychainaccess.plist

You may want to restart the computer and login as the real user. Keychain will ask you if you want to start over with default settings. Say yes to that. Then, logged in as the real user, start adding passwords by simply logging into the various services that user uses.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.