Is there a default sysman_pwd value

Hi,

When I create a database I get a warning that Enterprise manager configuration succeeded with the following warning -

Errorsecuring Database Control, Database Control has been brought up in non-secure mode. To secure the Database Control execute the following command (s):
1)Set the environment variable ORACLE_SID
2) C:\oracle\product\10.2.0\db_1\bin\emctl.bat stop dbconsole
3) C:\oracle\product\10.2.0\db_1\bin\emctl.bat config emkey -repos -sysman_pwd <PASSWORD for sysman user>

I complete steps 1 & 2 with no problem. But every time I try #3 I get the following error message:

Oracle Enterprise Manager 10g Database Control Release 10.2.0.4.0
Copyright (c) 1996, 2007 Oracle Corporation.  All rights reserved.

Invalid Password
caught Exception java.sql.SQLException: Io exception: Invalid Packet Lenght

I didn't know the sysman password so I logged into the database and changed it. I tested logging in as sysman with the new password. However, every time i enter the password in the above command I keep getting the same error message. I can log into other databases on other servers. However, I can't log into my own database. Could someone help me to trouble shoot and resolve this issue?
sikyalaSenior Database AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
Had to resort to Google.  Check the listener?

http://kr.forums.oracle.com/forums/thread.jspa?threadID=997915

It also looks like you can't just change the SYSMAN password from a SQL prompt once OEM has been configured:

http://download.oracle.com/docs/cd/B19306_01/em.102/b40002/repository.htm#sthref785
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
woolmilkporcCommented:
Did you obey OEM's password policy?
Passwords are required to be at least 5 characters long, with at least one number.  
Passwords must start with an alphabet character.
You may not  use any special characters in your password other than "-" (hyphen), "_" (underscore), and "$" (dollar).
wmp
0
sikyalaSenior Database AdministratorAuthor Commented:
When I check the listener I found it was not started. When I try to start it I get the following message:

The OracleOraDb10g_home1TNSListener service on local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.

When I try to test my listener file I get the following message:

Connecting...ORA-12569: TNS:packet checksum failure
The test did not succeed.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

slightwv (䄆 Netminder) Commented:
Try starting it manually from a command prompt:  lsnrctl start

Post back the errors you receive.
0
sikyalaSenior Database AdministratorAuthor Commented:
C:\>lsnrctl start

LSNRCTL for 32-bit Windows: Version 10.2.0.4.0 - Production on 07-APR-2010 12:05
:42

Copyright (c) 1991, 2007, Oracle. All rights reserved.

Starting tnslsnr: please wait...

TNSLSNR for 32-bit Windows: Version 10.2.0.4.0 - Production
System parameter file is C:\oracle\product\10.2.0\db_1\NETWORK\ADMIN\listener.or
a
Log messages written to C:\oracle\product\10.2.0\db_1\network\log\listener.log
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC0ipc
)))
Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=<mydbserver>)(PORT=1521)))
TNS-12542: TNS:address already in use
TNS-12560: TNS:protocol adapter error
TNS-00512: Address already in use
32-bit Windows Error: 48: Unknown error

Listener failed to start. See the error message(s) above...
0
slightwv (䄆 Netminder) Commented:
Do you have multiple ORACLE_HOMEs on this machine?  It's possible there is another listener running.

Check the status:  lsnrctl status
0
sikyalaSenior Database AdministratorAuthor Commented:
I only have 1 ORACLE_HOME. But there has to be another listener somewhere. I can't find it. I say this because although I can't connect to my local database I can connect to a database on another server.
0
sikyalaSenior Database AdministratorAuthor Commented:
when I type lsnrclt status I get the following:

TNS-12569: TNS:packet checksum failure
0
slightwv (䄆 Netminder) Commented:
>>I say this because although I can't connect to my local database I can connect to a database on another server.

The listener in a service running on the database server.  You don't need to worry about the remote ones, just the local one.

>>when I type lsnrclt status I get the following

check your local listener.ora file.  try using the loopback adapter: 127.0.0.1 in the HOST section.

you might also have a conflict with some other application using TCP port 1521.  You can do a 'netstat -a' to see if something is listeneing on 1521.

For grins you could go ahead and change the port in the listener.ora file and see if you can start the listener.
0
sikyalaSenior Database AdministratorAuthor Commented:
hmmm I do have other database servers running on this system (H2, SQL Server, Mysql). I know I had a conflict with the H2 database using port 1521
0
sikyalaSenior Database AdministratorAuthor Commented:
I found the database service that was using port 1521 and stopped it. Then I was able to start the listener
0
slightwv (䄆 Netminder) Commented:
Cool but if you need that service, just change the Oracle listener port in the listener.ora file.  This is recommended in Production systems since everyone knows the default.

Just make one up and use it.  Maybe the year you were born or your home phone...  It won't hurt a thing.
0
sikyalaSenior Database AdministratorAuthor Commented:
It turns out the problem wasn't the password it was the listener. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.