Laptop Toshiba Satellite L45-S7409 will not power on

Hello,

I have a Toshiba Laptop that was running just fine until the other evening.  It ran out of batteries and shut off.  I plugged it into the AC adapter and charged up the battery.  The next day I tried to power the laptop on but when I pressed the power button

1. I hear the CD rom get power
2. there is no usual fan noise
3. the display does not power on
4. The power light and battery light turn on
5. there is no hard drive indicator light
6. caps lock and num lock lights will not turn on
7. checked the ac adapter with a multi meter and read 19V
8. took out all RAM and there was no beeping
9. put one RAM stick in and tried to power on - no luck
10. removed the battery and AC cord for 24 hours and let it sit - no luck

Is there anything you would recommend I try.  Removed the hard drive and connected it to an external dock and it will power up.  

Cannot boot from a cd or the hard drive.  Other than the CD ROM noise - it doesn't spin just makes an initialization sound when I first power it on.  The Power light is the only other indicator anything is working.  The battery will still charge and turn from amber (charging) to green (charged)

Thank you!



networkadminAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
nobusConnect With a Mentor Commented:
it can be many things.
- a bad ac adapter (i know you tested it for 19 V, but it may fail under load) so test with a known good one
- a bad battery
-bad devices , blocking the mobo
here my laptop troubleshooting guide :
- if no display - test with an external monitor
- test also with a known good battery !
- remove battery and AC adaptor, hold power button for 20 sec, connect AC and reboot --> any display ? if NO -->
- disconnect all disk and cd drives, battery , and other cards and peripherals, leave only 1 ram stick
- boot -->any display ?
- if NO remove all ram and reboot --> if NO beeps, mobo or cpu bad ; if it beeps, replace ram stick

0
 
davidlevans13Commented:
You could try .... removing the battery and unplugging power cord and then press and hold the power on button for about 15-30 seconds and then retry.
0
 
networkadminAuthor Commented:
Tried that without any luck
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
davidlevans13Commented:
Bummer...
0
 
Arabia_vnCommented:
That could be battery problem. Have you tried turning it on without the battery or replacing it with another one ?
0
 
asiduCommented:
Use nobus troubleshooting guide.
Remove the battery out use  only AC.
You must first get POST right on power up.

Check the DC connector for possible damage/loose connection.
0
All Courses

From novice to tech pro — start learning today.