Secondary DNS server zones status: Zone Never Loaded

Hi,

I currently have 2 external dns servers: NS - 61.x.x.20 and NS1 -  61.x.x.32
I recently purchased 2 new DNS servers.

We are in the process of changing public IP address ranges so i have 2 separate ranges.
the new dns server ip's are: DNS - 203.x.x.9 and DNS1 - 203.x.x.10

All the zones on NS are primary with NS1. DNS and DNS1 as secondarys. if i make a change on NS, NS1 updates fine, DNS and DNS1 both dont update unless i do a manual f5 refresh on the zone. also DNS1 if i click properties, the zone status is Zone Never Loaded.

I have searched and no one seems to have experirenced the Zone Nver Loaded problem.

There is nothing in the event logs either.

Please Help!





justin_smithAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
luconstaConnect With a Mentor Commented:
But after "Reload" or "Reload from master" you see new hosts added to this zone? (try add a test A record to see if will be transferred).
Did you try a right click on the zone and select "refresh", maybe is just a "display problem"?
There are any error or warnings in the secondary DNS server's log?...
0
 
luconstaCommented:
Are you sure you coreclty configured the zone transfers (are the secondary DNS allowed to transfer from master)?... here is an article that may help you: HOW TO: Configure a Secondary Name Server in Windows Server 2003.
0
 
Chris DentPowerShell DeveloperCommented:

This is incomplete:

> All the zones on NS are primary with NS1

Was it supposed to say NS1 holds Secondary zones?

Test DNS and DNS1 have permission to transfer the zone by running this on each:

nslookup
server ThePrimaryServer
ls -d whateverzone.com

If you get Refused, or it fails in any way they will not be able to transfer the zone within DNS itself.

Chris
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
justin_smithAuthor Commented:
yeah sorry, it was supposed to be a comma, not a full stop
> All the zones on NS are primary with NS1, DNS and DNS1 as secondarys

I have done the tests on all dns servers. they all are fine with no errors.
0
 
Chris DentPowerShell DeveloperCommented:

> I have done the tests on all dns servers. they all are fine with no errors.

Can you check the NS and SOA records in the bit of the Secondary zone it presumably does have? They must match up with the Primary or the Transfer will fail.

Chris
0
 
justin_smithAuthor Commented:
Chris,

i have checked the NS and SOA records and they are fine.

Just to reiterate, the records do get transfered across, it just takes an F5 press to get it to show the right data.

The other thing that worries me is if i click on the properties of a forward lookup zone, the status says: Zone never loaded

this is only on the servers DNS and DNS1 which are server 2008.

although randomly it says: status running, but the majority of the time it is Zone never loaded

Thanks
0
 
Chris DentPowerShell DeveloperCommented:

It wouldn't be the first time we've had problems with DNS on 2008. What DNS service are you running on the primary server?

Chris
0
 
justin_smithAuthor Commented:
the primary server is Server 2000
0
 
justin_smithAuthor Commented:
Hi Chris,

Any more help with this?

Thanks
0
 
luconstaCommented:
On the main server I assume you allowed the zone transfers because you said it can be done manually, but did you configure the "Notify" option?... to automatically notify the secondary servers?... because by default notifications are not configured, you have to set the notifications by yourself.
0
 
Chris DentPowerShell DeveloperCommented:

Sorry, lost track.

Can you check the DNS event logs and see if any messages are logged regarding the transfer? It could be that it's timing out.

Chris
0
 
justin_smithAuthor Commented:
Chris, luconsta,

It seems like the transfers are fine now. I just have the one outstanding thing, which is the Zone never loaded issue. any thoughts on that?
0
 
luconstaCommented:
Try to do an "load from master" or "reload" to see if the status will change...
0
 
justin_smithAuthor Commented:
no change...
0
 
justin_smithAuthor Commented:
not really the answer.
0
 
luconstaCommented:
Thank you justin for the points but is not necesary to give the points if your question is unanswered.
Did you finally solved your problem by yourself or at least have a possible answer?...
0
All Courses

From novice to tech pro — start learning today.