Citrix problem connecting remotely

We have a Citrix Metaframe XP server that clients connect to both when in the office and remotely. One of the users can connect fine when in the office from his Vista laptop, but when connecting remotely (via the external IP address) from that same laptop he gets the following error message :-
"The system cannot find the file specified. The initial program cannot be started: Home Network. Please consult Help for more details"

It's obviously making the connection as you can see the login script running before the above message appears, and after clicking OK to it, the system closes down the connection with the normal 'logging off'' type prompts.

We've compared the properties of the 'Home Network' connection with other users and it;s identical, and the other users can connect OK. Also, I've changed the user so that he has administrative priviledges and the same thing happens. This user can use another laptop and connect remotely without issue.

Therefore I assume it must be something to do with his laptop, but any ideas what the client might be objecting to?

Thanks

Mike
LVL 1
TS_MikeHAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dnsguru44Commented:
Hi... this is an odd one.  Just to be clear, we are talking about one laptop that Can connect when in the office but not on his home network, correct?  Also, when you mentioned that the user "can use another laptop and connect remotely without issue" I am assuming it's a similiar laptop with same OS and connecting via his/her home network, correct?  Thx
0
johnb6767Commented:
""The system cannot find the file specified""

Assuming this is in reference to the .ICA file?

Hate to offer a simple suggestion, but you might try emptying the Content.ie5 folder in the TIF's.... Dont always get emptied....

Start Button>Run>"Shell:cache>Content.ie5"

CTRL+A, and delete all..... It will bomb on Index.Dat though.....

Then retry....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thabashCommented:
try this
start->run
regedit
hklm-software-microsoft
locate the mslicencing
right click on mslicencing and delete

try now to access through citrix
hope it should work
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

TS_MikeHAuthor Commented:
Initially I created a new connectiion and the same problem occurred. I tried all of the above suggestions but the problem persisted.

However, after doing the above (and I've no idea whether they helped or not, as there were a few restarts, probably some windows updates etc going on a s well) I created a new connection again and this time it worked.
0
TS_MikeHAuthor Commented:
Not sure whether the 'solutions' give had any effect, but thanks anyway for the reponses
0
johnb6767Commented:
Glad its fixed....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.