Erros Sending Emails from SBS 2008 Exchange

Emails are not being sent from our server running SBS 2008 Standard, Exchangs is configured to send and receive mail and has been working fine for the last couple of weeks. The server was rebooted and now emails sit in the queue. However, emails are being received fine. We use a smart host and they say that they cannot see the server connecting to them at all.
The error is: 451 4.4.0 primary target IP address responded with ". " attempted failover to alternate host, but that did not succeed.Either there are no alternate hosts, or delivery failed to all alternate hosts.
Any ideas

LVL 1
Li0nelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Syed Mutahir AliTechnology ConsultantCommented:
http://support.microsoft.com/kb/951291

At the command prompt, type the following command, and then press  ENTER:netsh interface tcp  set global                         autotuninglevel=disabledThis command  disables  the Receive Window Auto-Tuning feature.
Exit  the Command Prompt window.
Restart  the computer.

Have a look at the link above and apply the fix, make sure you have a latest backup first before making any changes.
0
Syed Mutahir AliTechnology ConsultantCommented:
Double check your send connector authentication,
From your Exchange server, try to telnet to your SMART HOST ADDRESS on port 25 to see if it connects ?


I will check back to see if that helped or not.
0
Li0nelAuthor Commented:
I have checked the authentication and if that were the problem the smart host company would have seen the server being rejected. They assure me thay cannot see the server connecting.
I have tried to telnet to the smart host and that failes.
I have checked my router and port 25 is open. I have also checked the firewall on the server and port 25 is open on that.
Any ideas?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Syed Mutahir AliTechnology ConsultantCommented:
if the telnet to smart host is failing then there is something else blocking - on the provider side

smart host is prodived by the provider ? what port have they given you ? is it 25 or something else ?

if it is not 25, then telnet like the following way :

start > run > telnet smarthostaddress 111                      change 111 to the port number given to your company by the provider.

http://www.canyouseeme.org/

you can use the above website to check if port 25 is visible from the outside (it should be)
I think your provider has done some config change or port number change or may be a firewall in between ;

if you cannot telnet to the smart host , then its not your problem, as long as your EMAIL Server port 25 is open.

check your Send connectors as well, what port is there
0
Syed Mutahir AliTechnology ConsultantCommented:
EMC > Organization Configuration > Hub Transport > Send Connectors >

Right click on the send connector and select properties

Click on the Network tab and double check the "route mail through the following host" have the proper entry for your smarthost and any authentication settings too. (if provided).


0
Syed Mutahir AliTechnology ConsultantCommented:
What was the last change you made on your server ?
Why was it restarted ?


0
Li0nelAuthor Commented:
I have applied the auto tuning fix and will reboot the server tonight. I will let you know if it works.
0
Syed Mutahir AliTechnology ConsultantCommented:
Do try the telnet to your smarthost on the correct port as specified by your provider, check the authentication settings too.

if you cannot telnet to the smarthost on the specified port (provided by your provider) then its your provider.;
0
Li0nelAuthor Commented:
Server was restarted due to symantec backup not restarting its services
0
Li0nelAuthor Commented:
turns out mcafee was blocking this port to that IP range :/

  uninstalled and working fine
0
Stuball2Commented:
Hi Lionel,

Rather than uninstalling McAfee, you cna turn off the access protection rule in "anti-virus standard protection" entitled "Prevent Mass mailing works from sending mail", this is simply blocking port 25..
0
Syed Mutahir AliTechnology ConsultantCommented:
Interesting - as I thought so that there is a firewall in between somewhere blocking - and it was infact the one in your network (Mcafee AV).

"I think your provider has done some config change or port number  change or may be a firewall in between"

Glad it had resolved for you.

Have a good weekend
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Li0nelAuthor Commented:
provider sorted problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.