MRTG graph problems

I've got MRTG setup on a CentOS 5.3 32-bit machine running in Virtual PC 2007 on a Windows XP SP3 box.  

I noticed that the time for my graphs was incorrect, and the time on my CentOS virtual machine was also incorrect. To correct time I used hwclock to set the time to current time.  Now my MRTG 5 minute avg graphs are blurry, and some are not returning any data at all.  I rebooted the machine, remade the mrtg.cfg and the index.html files, but I still have the problem.
mrtg-graph.jpg
LVL 8
sharkbot221984Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ajay_mhasalCommented:
HI,

You need to delete files from your output directory of MRTG and regenerate those using indexmaker and mrtg command.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sharkbot221984Author Commented:
Thank you ajay, I removed all the device files from the working directory and ran indexmaker to recreate them, I have un-blurry graphs now.

Already I can see the time drift on my box, it was set correctly a few hours ago, no it is almost 2 hours ahead.  Any idea?  Seems that this may be an issue with it being virtual.
0
deepak_iqCommented:

What is the present /etc/ntp.conf configuration? Have you mentined the ntp servers ip details?If not,kindly add the ip in the configuration file.

Is ntp service running on the server?
Check by:
#/etc/init.d/ntpd status

If not running,run it:
#/etc/init.d/ntpd start

To check the status then:
#ntpq -p

Check for any ntp related errors in /var/log/messages.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ajay_mhasalCommented:
HI,

Now set the time as follows

# date mmddhhmm  

Above format is (mm=month, dd=date, hh=hours, mm=minutes)

Now use following command

# hwclock --systohc

I hope this will work for you!
0
sharkbot221984Author Commented:
Thanks guys, ntp was not turned on, I turned it on and set the date again.  The ntp.conf file I assume is default?  It is using the public pool servers.  I will monitor to see if it stays on track now.
0
sharkbot221984Author Commented:
The time has drifted again still.  It was correct as of my last post, and now as of this post it is 4 hours ahead.
0
sharkbot221984Author Commented:
Thank you for your help.  I ended up setting up Sun Virtual Box instead of MS Virtual PC, and re-setting up my MRTG server on there.  Time has not drifted at all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.