2003 mailboxes not sending to 2010 mailboxes

I've got a newly installed 2010 exchange server next to my production 2003 exhcange box.  We utilize an ironport smart host device that is set up on the Internet Mail SMTP connector  For some reason internal emails from mailboxes on the 2003 box intended for mailboxes on the 2010 box are getting stuck at the smart host.
LVL 1
tfgeorgeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
This would normally happen if the SMTP Virtual Server had a smarthost configured.
Check the properties of the SMTP Virtual Server you can find it under Administrative Groups > First Administrative Group > Servers > Servername > Protocols > SMTP

You may also want to remove the Internet Mail Connector and setup a new Send Connector for your smarthost
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AkhaterCommented:
This happens if smart host configuration is done at the  SMTP virtual server level and not as SMTP connector

please remove the smart host from the SMTP virtual server and create a send connector instead
0
tfgeorgeAuthor Commented:
The smart host config is not done at the SMTP virtual server.  It is configured at the internet mail SMTP connector (Admin groups,1rst admin group, routing groups, routing group, connectors, Internet SMTP Connector)
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Glen KnightCommented:
Can you delete the Internet SMTP Connector and create a Send Connector I stead.

Exchange 2003 will automatically forward mail through Exchange 2010 and then through the Send connector to the Internet.

It may also be worth double checking the Virtual Servers as this is what Exchange uses to send email between exchange servers and if a smarthost was configured in here then it would cause what you are seeing.
0
tfgeorgeAuthor Commented:
The SMTP connector is production and I would really prefer to avoid that.
0
Glen KnightCommented:
There is no other reason why this wouldn't work.

Have you checked the Virtual Server?
0
tfgeorgeAuthor Commented:
demazter you are right!  the virtual server also has a setting in a very sneaky little place.  So can I
0
AkhaterCommented:
if you have the connector setup on the connector then remove it from the virtual server
0
Glen KnightCommented:
As I said in my first post remove this.  These settings should always be configured in an SMTP Connector not on the virtual serve.

Exchange uses the virtual server to send between exchange servers if you have a smarthost configured then it will send to thatbinstead of the exchange server.
0
tfgeorgeAuthor Commented:
So if I remove the smart host from the SMTP virtual server properties it will not affect mail flow for my production 2003 exchange server???
0
Glen KnightCommented:
Once you have made the change you may need to restart the Simple Mail Transfer Protocol service for it to take effect.
0
Glen KnightCommented:
No it will not
0
Glen KnightCommented:
The SMTP Connector you have configured for Internet mail will apply the settings you have configured to the Virtual Server when the criteria specified in the connector is met.
0
tfgeorgeAuthor Commented:
you rock demazter
0
tfgeorgeAuthor Commented:
Excellent
0
tfgeorgeAuthor Commented:
well, changing the virtual server DOES break the 2003 mail flow
0
Glen KnightCommented:
It shouldn't do if the SMTP Connector is configured correctly.
0
tfgeorgeAuthor Commented:
You are right demazter BUT, ironport requires port 28 for outgoing.  The only place to specify that port is in the SMTP virtual server.  So I need another solution.  Possibly setting up a second SMTP virtual server on a different port for mail to flow from 2003 to 2010
0
Glen KnightCommented:
No, setup a send connector to go to the port that is required and make site the Virtual Server is set to port 25 or it will not sed mail to the 2010 server.

The send connector is the same as the SMTP Connector and once you have mailflow between the 2 this will be used instead

this is how it's designed to work.
0
tfgeorgeAuthor Commented:
demazter - I can't setup a send connector to ironport on port 28.  The virtual SMTP server is the only place to specify a port for that and it has to be on port 28 not 25
0
AkhaterCommented:
no you can't you smtp virutal server should be configured to send on port 25 for routing between 2003 - 2010 to work

your only option is to switch outbound mail to 2010 and crate a send connector on 2010 to send to iron port on port 28 (or swtich your iron port on port 25)
0
Glen KnightCommented:
YoU can set a send connector to use port 28 you just have to use the Exchange Management Shell and the Set-SendConnector command please see here for more information: http://technet.microsoft.com/en-us/library/aa998294.aspx
0
Glen KnightCommented:
Just make sure once you have configured the send connector that you set the Virtual Server to port 25.  If you don't mailflow between the 2 servers will never work
0
Glen KnightCommented:
So the command would be:

Set-SendConnector -identity "connector name" -port 28

replace connector name with the name of your send connector
0
tfgeorgeAuthor Commented:
I can't set the 2003 serer to port 28 unless I use virtual smtp connecter.  I know that I can set this up on the 2010 box
0
AkhaterCommented:
for mail flow to work between 2003 and 2010 the virtual server should be set on port 25 there is no way around this.

you have 2 options

1) send the iron port on port 25
2) route the outbound traffic to 2010 and create a send connector on port 28 on the iron port
0
Glen KnightCommented:
Ok, the 2003 server will send mail via the 2010 server so you don't need to set it to port 28.

As long as there is no smarthost in the Virtual Server and it's set to port 25 then by default it will use the 2010 send connector to send mail.

So all you need to do is configure the send connector on the 2010 server set the virtual server to port 25 and remove the smarthost entry.
0
tfgeorgeAuthor Commented:
I tried removing the smart host from the virtual smtp server in exchange 2003.  It broke outbound mailflow for mailboxes on the 2003 server.  The send connector on 2010 is already setup to go to the smart host
0
tfgeorgeAuthor Commented:
currently for the 2003 box the smart host is setup on both the SMTP virtual server AND the Internet MAIL send connector
0
Glen KnightCommented:
Do you have a routing group connector configured between the 2 servers?
0
tfgeorgeAuthor Commented:
there is a routing group connector
last time when I removed the smart host from SMTP virtual server it was still listed in the Internet Mail Connector.  What I would like to try is removing it from both (after hours) and see if exchange 2003 will be smart enough to route external email through 2010.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.