Can't connect to Report Server to publish reports

Hi,

I'm trying to use SSRS for the first time.  I probably should do all of this on Server 2008, MSSQL 2008 and VS 2008 but I can't right now.  Thus, I have XP Professional, MSSQL 2005 and VS 2005.

I have created a report within Visual Studio and I am attempting to publish it.  I have configured the Report Server (see picture below).  However, I can not publish the report or get access to the following URL:

http://localhost/reportserver

The Report Server is of course local.  The error I get from the Browser is:

HTTP 401.3 - Access denied by ACL on resource
Internet Information Services

... and the error I get from Visual Studio when I attempt to Publish is the same.  In either attempt I am prompted to log in.  Notice in the picture below showing the Windows Service Identity, I have successfully assigned my System/Windows logon.

This same logon is assigned to the ReportServer Database within SQL Server Management Studio.  It is assigned as the default database !

Therefore,  my questions:

1)  why on earth would I not be able to Publish the report or access the ReportServer URL?  
2)  Is there some object level permission within SQL Server Management Studio I need to assign?
3)  Should the ACL able to be modified to correct this and how?
4)  Is the ASPNET user the one actually executing

The Web Service runs under the ASP .NET machine account (server_name\ASPNET) under IIS 5 or under the context of an application pool ...

I have also looked under DCOM CONFIG at the NETMAN properties and everything looks right there.

What then is it?

Thanks!

Report-Server.JPG
Report-Server-2.JPG
John500Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
BodestoneConnect With a Mentor Commented:
Hmm, mine are set up to use LocalSystem for the windows service and NT Authority\NetworkService as the web service Identity as was initially set up by SQL server.

Also, For the browser viewing of the reports my url is HTTP://machineName/reports

Credentials are not correctly passed in unless using IE and if using another browser the full domain/username is required (though not sure if this appies to you on a local install or if you need the machine name for a totally local user)

When you publish though I believe that it is the credentials for the currently logged in user that are used to determin publishing rights. I am assuming you have those rights or you would not be confused.

Just a few thoughts to throw into the mix since these things are often hard to troubleshoot from afar. I'll have more of a ponder though.
0
 
John500Author Commented:
Appreciate the input here!

>>  mine are set up to use LocalSystem for the windows service
I changed this to LocalSystem successfully

>>  ...and NT Authority\NetworkService as the web service Identity
I don't see how to changes this.  Have any ideas?

>> Also, For the browser viewing of the reports my url is HTTP://machineName/reports
This didn't work either.

>> Credentials are not correctly passed in unless using IE
I'm using IE

>> When you publish though I believe that it is the credentials for the currently
>>  logged in user that are used to determin publishing rights
This is my machine and therefore I have full rights... but it ain't working

>> I'll have more of a ponder though.Accept as Solution
Thanks!
0
 
BodestoneCommented:
What's the screen shot when you click on the Web Service Identity option just below Windows Service Identity?

What hapens if tou replace localhost with your local IP, 11.0.0.1 or machine name?

Were you using IIS for any other websites before installing reporting services (could be a conflict there if so)

Oh, are you using Express Edition? My express edition was set to http://localhost/reportserver$sqlexpress
and http://localhost/reports$sqlexpress for the web interface

You can tell though just by looking in the IIS interface.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
John500Author Commented:
>> What's the screen shot when you click on the Web Service Identity option
See the picture below.  How can this be changed to the setup you have?

0
 
John500Author Commented:
Oops forgot the picture.....

>> What hapens if tou replace localhost with your local IP, 11.0.0.1 or machine name?

Same thing, I'm forced to log in.

>> Were you using IIS for any other websites before installing reporting services (could be a conflict there if so)

Yes, but just fooling around.  The properties are seen in the 2nd shot below.  This doesn't look right does it?

Report-Server-3.JPG
IIS.JPG
0
 
BodestoneCommented:
Ahh, sorry. i had been looking at the one on my server. On my local machine it is the same for web service.

Hmm, interesting, My windows service on the local machine is set to run as NT Authority\NetworkService.
Probably won'r help though.

On the properties for the 2 virtual directories Reports and ReportServer:
Directory Security and Edit anonymos access and authentication control.
Id it set to Integrated Windows Auth?
iisauth.gif
0
 
John500Author Commented:
Yes, both virtual directories were already set up like that as seen in the picture below.  However, setting Integrated Windows Auth. on IIS doesn't affect the Report Server so that the Web Service Identity changes.

Do see what I'm getting at?
IIS2.JPG
0
 
BodestoneCommented:
Yes, but if the web virtual directory was not configured to accept windows authentication then your credentials could not have been passed via the web service to authenticate you to publish I believe.
It was just another longshot and one more possible cause eliminated.

As I said, on my local installation the Web Service is set up as yours is so it's not that either.
0
 
John500Author Commented:
>> As I said, on my local installation the Web Service is set up as yours is so it's not that either.

so you're saying your local installation (Report Server) also has the ASPNET user set as the Web Service Identity?
0
 
BodestoneCommented:
Yeah. initially I had been looking at the setting on the server side one rather than my local test bed. I think it's an IIS5 VS IIS 6 thing.
0
 
John500Author Commented:
I decided to just upgrade to 2008 and see how that clears things up.  I needed to do that any how.

Thanks
0
 
BodestoneCommented:
Cheers for the points then since I was not actually able to help with your issue. Hopefully the comments will be of help to someone else with similar issues though.
0
All Courses

From novice to tech pro — start learning today.