SBS 2008, clients cant connect pop3 or imap

Hey Guys,

I migrated a SBS 2003 server to SBS 2008 over the weekend and have run into an issue with clients not able to connect outlook or mobile phones to the server via pop3 or imap.  I seem to be able to authenticate with the server to download mail but not send.

I tried to telnet into server and running a EHLO command but i get:  "-ERR Protocol error. 19" as a result.  Active sync and RPC are working beautifully by the way...

Does anyone know what this is or what could be causing it?

Thanks in advance.
LVL 2
breynolds01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

breynolds01Author Commented:
I probably should have mentioned that both the pop3 and imap services have been put on auto and started.  I can telnet into the server over port 110 but when i try a EHLO command i get "-ERR Protocol error. 19" as a result.

0
ConchCrawlCommented:
Have you run the connect to the internet wizard?
Have you run the set up your internet address?
Have you run the add a trusted cert wizard?
Can you run the fix my network wizard and post the results here?
Also, you may want to download the Best Practices Analyzer for SBS 2008 and post the results here after you run it of course :-).
0
breynolds01Author Commented:
I have ran the connect to the internet wizard
I have setup the internet address
i have added a trusted cert
when i run the fix my network wizard it complains about not using root hints for the DNS server since I'm using forwarders

nothing is being flagged on the  best practices analyzer but i only ran the health check.
0
ConchCrawlCommented:
This is error is being caused by the sequence of commands, when you are telneting to 110 for pop3 it is looking for user / passwd /list not EHLO like smtp (25).
Try it again that way, there are also other consdierations in the way you are configuring this I would look at that might make your life easier, but let's see if we can get past this problem first :-).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.