• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1725
  • Last Modified:

Getting "The RPC Server is unavailable" errors when trying to connect to SSIS

We have a SQL 2005 Server on which we are having trouble connecting to SSIS.  I can connect to the database engine and run queries just fine, but I can not connect to integration services.  We've tried connecting from several PCs to no avail.  The error that we are getting is:

"Failed to retrieve data for this request.  (Microsoft.sqlserver.smoEnum)  
            The RPC Server is unavailable. (Exception from HRESULT: 0x800706BA)
            (Microsoft.SQlServer.DTSRuntimeWrap)
                    The RPC Server is unavailable. (Exception from HRESULT: 0x800706BA)
                     (Microsoft.SQlServer.DTSRuntimeWrap)

The SQL server is behind an internal firewall, and ports 3882 and 135 are open from our source IPs.  The firewall logs show attempted connections on odd ports like 3646 ??  Why would the ports be changing?
0
okacs
Asked:
okacs
  • 6
  • 5
1 Solution
 
okacsAuthor Commented:

Note:  When I open port 3646 on the firewall, connections to SSIS work.  But after about a month, it stops working.  Checking the logs will reveal that SSIS connections have moved on to yet another port number again....  I cant keep swiss-cheesing my firewall for this!
0
 
BanthorCommented:
SQL Broker Services trys to use other available ports.
Try setting the server name in your connection string to TCP:[IPADDRESS]:PORT
 
0
 
BanthorCommented:
Example:
TCP:192.168.1.99:1433
 
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
okacsAuthor Commented:
I tried that.  

I get the error "Cannot connect to TCP:<ip address>:1433"  "Connect to SSIS service on machine TCP:<ip address>:1433 failed.  The RPC server is unavailable.

Tried this with and without the "TCP" and with several different ports that are all allowed in the FW rules.

Still can't connect.
0
 
BanthorCommented:
Yes, 1433 is the default port you are using 3882  TCP is correct, but the colon [Port] is wrong. STill checking BOL
I know I am close to the right answer.

0
 
okacsAuthor Commented:
Yes, I tried the above with using port 3883.  I am still unable to connect unless I specifically open port 3436 in the firewall.  <Sigh>  Why does it want to use 3436???
0
 
okacsAuthor Commented:

#$(*&^(*&$#%(*&$  ARGH !!!!!!!!  

It was working fine with a port open for 3436 but now it wants to use port 2499!

I cant keep making Swiss-cheese out of my firewall!!!  

HELP!!
0
 
okacsAuthor Commented:



THIS PROBLEM WAS NOT RESOLVED, BUT THE QUESTION CANT REMAIN OPEN.  ADMIN WANTS TO MARK IT ABANDON AND DELETE IT.    :(

Banthor, thanks so much for all your help.  I Will close the ticket award points for your assistance!
0
 
okacsAuthor Commented:
I guess we didn't find an answer, but Thanks so much for all your help!
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now