Direct OWA url to mailbox Exchange 2010 vs Exchange 2003

We have users that don't have a mailbox but have an account in AD.  They use a shared mailbox that they access via OWA by going to the direct URL of https://mail.domain.com/exchange/username.  This works well.  Now with Exchange 2010, I can't get it to work unless I make a mailbox for each user, then the direct url works and they can get in.  Did something change from 2003 that requires users to have their own mailboxes in order to open other mailboxes?
jpletcher1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

terminateallCommented:
Try to give mailbox permission to these non-mailbox users from EMC.
Under recipient configuration----go to the mailboxes which you want to be accesed by these non-mailbox users.
0
jpletcher1Author Commented:
All of the non-mailbox accounts already have Full Permissions and Send As permissions to the mailboxes.  This is how it was able to work before. I also verified by looking in the EMC again.
0
jpletcher1Author Commented:
Figured out a little bit more...

If I go to https://ServerIP/owa/sharedmb@domain.com   it gives a cert error, but logs in fine with no credentials prompt
If I go to https://NETBIOSName/owa/sharedmb@domain.com  it gives a cert error, but logs in fine with no credentials prompt

What I want to work, and what our cert is set for (mail.domain.com), is:
https://mail.domain.com/owa/user@domain.com   when I use that, I get no cert error, but it asks for credentials and keeps refusing them until it gives a 401 error.

My internal and external OWA urls are set to be https://mail.domain.com/owa
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Shreedhar EtteCommented:
Have you tried to access like this:

https://mail.domain.com/owa/user
0
LeeDerbyshireCommented:
If it is only mail.domain.com that doesn't work, then it may be a DNS issue.  For example, internally, your DNS name mail.domain.com may be resolving to your public IP address.  This will probably mean that you are actually trying to access the admin web pages on your router.
0
jpletcher1Author Commented:
shreedhar - yes, I've tried that.  Seems like I have to use IP or NETBIOS name for it to work and not mail.domain.com

LeeDerbyshire - I have tried usinga hosts file telling it that mail.domain.com is the IP of the new exchange server, so it should be pointing correctly.  Also when I get the 401 error that comes from the new Exchange owa site.
0
jpletcher1Author Commented:
Another strange thing, thia all works fine on my windows 7 computer with IE 8, it logs right in for the shared mailbox.  But not a windows xp machine with IE 6 or IE 7.  There is just keeps prompting for username and password.  I'm guessing there is some form of authentication issue.
0
Shreedhar EtteCommented:
Hi,

In Internet Explorer on Windows 7 check the User Authentication Settings.

Go to Tools> Internet Options> Security> Internet > Custom Level > Scroll Down to Last there you will find User Authentication > Check what Logon type being user.

Check this setting for the Internet and Local intranet.

Then verify the same settings are there on the Windows XP System.

I hope this helps,
Shree
0
jpletcher1Author Commented:
Both setups are set to Auto Logon only in Intranet zone for the two Internet and Local Intranet.  So from that standpoint they are the same.
0
jpletcher1Author Commented:
Just to give a recap..

Our certificate is "mail.domain.com"  This resolves internally and externally to our Exchange 2010 server.

Externally, going to https://mail.domain.com works.
Internally, going to https://netbiosname/owa and https://ipaddress/owa works, althought there is a cert error that we have to click OK on.  Internally, https://mail.domain.com prompts for credentials and then does not accept them and eventually gives a 401 error that is from IIS on the Exchange 2010 server.

As for the logging in directly to another user's mailbox, we also had to first log in as the actual user of the mailbox, then another user could connect directly to it after that, but not before.  
0
Shreedhar EtteCommented:
Hi,

https://mail.domain.com/owa/username

Make sure logged on the any of the workstation or server with the user who has been granted the permissions for the other user mailbox.

I hope this helps,
Shree
0
jpletcher1Author Commented:
At this point, internally we can't even log in as ourselves using:

https://mail.domain.com
https://mail.domain.com/owa
or
https://mail.domain.com/owa/username

We can only log in using the netbios and IP with /owa.
0
jpletcher1Author Commented:
I think the issue now is not so much that I can't get to the direct URL as it is I can't use the URL that I want.  The solution to not being able to use a direct URL to another user's mailbox I found was that the original mailbox has to be logged into once after it was moved to Exchange 2010 before other user's can use a direct URL to it in OWA.  I am going to repost this as a different question.

Thank you all for your input on this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shreedhar EtteCommented:
Hi,

Does any of the posted comments assisted you to reach the conclusion? If yes, then award partial point.

--------
Shree
0
jpletcher1Author Commented:
What made us able to login to a direct url to another user's mailbox was to first have the other user login as themselves and open the mailbox on the new server, then after that another user could connect to it through a direct URL.  I do appreciate all the troubleshooting and help, but none of the suggestions mentioned this or pointed me in that direction.  I don't want to mark something as an accepted solution and have someone looking at this down the road think that's what fixed the issue.  With that said, I hope that doesn't make this sound rude or unappreciated by any means, because I do appreciate everyone's help and contributions on here.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.