how to setup A share located on another computer

We have FTP server iis5.0 We need configure FTP server to connecto remote server root directory.

Please advice
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hi tkshatriya,

IIS 5.0 ... is this a Windows 2000 Server!?! You really should consider upgrading. :)

To specify a remote network share as the FTP root directory, try the following:
1) Within the IIS snap-in (%SystemRoot%\system32\inetsrv\iis.msc), expand the FTP Sites tree and right-click the name of the FTP site (e.g. Default FTP Site).
2) Select Properties.
3) Click the Home Directory tab.
4) Click the radio button next to "a share located on another computer."
5) Within the FTP Site Directory section, specify the remote server root directory in the Network Share: text box.
6) If necessary, specify desired permissions and auditing options (Read/Write/Log visits) and directory listing style (UNIX or MS-DOS).
7) Click OK.

See the attached screenshot or the links below for more information.
Hope this helps!

tkshatriyaAuthor Commented:
Thank you for quick reply. So how do i change my FTP directory to a share located on another computer

currenlty the a share located on another computer is grey out

Based on your screenshot, this looks like a Web site/virtual directory and not an FTP site, as mentioned in your original post. My apologies for the confusion!  :)

There's also an ASP.NET tab in your screenshot. Was CRM_TEST built using the ASP.NET Web Site wizard in Visual Studio?

If so, I was able to duplicate the issues you're seeing (relative path in the Local Path field, Browse... button missing, "share located on another computer" option grayed out) by using VS2008 to build a new ASP.NET application within the same root folder as the existing Web Site in IIS (i.e. c:\inetpub\wwwroot\CRM_TEST). In my case, a virtual directory was created under the Default Site and (just like you) several options are grayed out (see attached).

Others who have experienced this problem (You're not alone!):
If the scenario above matches what you're experiencing, one possible workaround is to:
1) Recreate the CRM_TEST folder as a virtual directory in the IIS snap-in.
2) Configure a remote path as desired (UNC path to your FTP server).
3) Publish your ASP.NET app to the same remote location on your FTP server using Visual Studio (FTP option ... not the Local IIS one, as I'm assuming).
4) Fix up any ASP.NET linkages between the two (I'm not an ASP.NET developer!)

Hopefully this helps! Let me know if you're not using ASP.NET, or if I'm missing the point of what you're trying to accomplish here.

Thanks for your patience ...

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Hi tkshatriya, just following up to see if the recommendations above were of any help. Any luck with what you were trying to accomplish?

tkshatriyaAuthor Commented:

Sorry for replying late and for confusion. I didnt ask questions clearly. I created the new web site using remote server connection. When i right click on test web site i created and clikc on explore i can access the folder which is stored on remote server.

When I ping the FTP server I dont see any directory/site created with new information. ?

can you please shed light on this.

thank you
Can you provide the SPECIFIC steps used to "create the new web site using remote server connection?" Did you do this within the IIS MMC, or using the New Web Site wizard within Visual Studio?

Any detailed information you can provide will help narrow down the problem. Sorry this is so difficult via posted support!  :)

tkshatriyaAuthor Commented:
Here is steps.

1) clikc on start, Program , Admistrative tools, Internet servic emanager
2) Clikc on tab to view Ftp server name
3) Right click on to create new FTP site to connect to remote server (I'm using port 22 as other FTP site is using 21)
3) Create web site to remote pc computer and connect to remote server.

I'm attaching screen shot.
tkshatriyaAuthor Commented:
Thank you mark, Appericaite your help !!

tkshatriyaAuthor Commented:
I'm sorry for the cofusion. Let me explain what exactly I'm trying to achieve here.

I have the default ftp-site an a new one (which i configure to connect to remoter server to store the file ) on the same IIS 5.0 server. it's using same IP address and defulat is using 21 and new one using 22 Now.

When i type in browser ftp://mywebserverIpaddress i see result (like directorys)
what do i need to type in browser to see new connection ????


To access the secondary site, use ftp://servernameORipaddress:22/CRM_TEST
Note that port 22 is reserved for SSH, so IIS may prompt for credentials if going this route.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tkshatriyaAuthor Commented:
Thank you Mark.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.