• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3660
  • Last Modified:

Can't FTP into IIS on Windows Server 2008 R2

I'm just setting up our new Windows Server 2008 R2 environment and am unable to FTP into my default FTP site.  

I've enabled Anonymous and Basic Authentication - Given Authorization to Anonymous Users, and my the Administratrs group which I'm loggin as.

I've made my default folder open to just about everything.

I've verified the IP and the port (2121), but can't connect.  Totally lost....  This should be simple.

Does it have anything to do with the Application Pool?


  • 3
  • 3
2 Solutions
Start with verifying that it works from the server itself. That would help identify an app problem.
JT_SIROAuthor Commented:
I  installed Filezilla on the server and put the ip, username, passsword, port - and it did not connect.  I got the same message:
Connection attempt failed with "ECONNREFUSED - Connection refused by server".

I am supposed to connect with windows user credentials from that server, right?  I don't set up username/password in IIS FTP do I?
if you have enabled anonymous and have a browser on the server, you should be able to connect.
btw: ftp standard port is 21.  should work, at least.
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

JT_SIROAuthor Commented:
Windows Server 08 is running as a VM on a Mac.  Port 21 is take by one of the other instances.  I was given 2121 and

I put that ip in my browser and it says it can't establish a connection.  Any ideas?

This install of Windows Server 08 R2 has been terrible.  I can't even get SQL Server to install.  I almost wonder if it's corrupt.
On the server itself try  ( is the local loopback address).
Brad HoweDevOps ManagerCommented:

1. From your desktop, open a terminal window of command prompt (whatever is the equvilant on MAC) and try the following.
                            telnet yourserver.ftp.com 2121

This should at least connect, if it timesout, you are firewalled or the service is not running.

Next, take a read at the iisnet forums on how to configure FTP services on IIS7.*. This should like a firewall issue.

Last. ->> "I can't even get SQL Server to install." You need to disable UAC or right click on the setup.exe and RUN AS ADMINISTARTOR.

JT_SIROAuthor Commented:
It turns out our admin used 2121 for the machine my VM is running on, then redirected to my VM where the default 21 is used.  I had set my IIS FTP site to look at port 2121.

Thanks for your help
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now