[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 607
  • Last Modified:

Cisco ASA 5505 Remote VPN IPsec - cant access internett

Sorry for this question, I guess that the answer surely is clear as the sun when you know what you’re doing, which I am clearly not at the moment!

But I can not in any way connect to the internet while using the Cisco IPsec VPN with Cisco VPN Client.
I can ping local devices, but it seems like the whole world wide web have disappeared into /dev/null, sins it’s nowhere to bee seen.

Could you take a look at this for me?

I have read a lot of other similar cases around the web, as well as here, but it ends up with yet another trip to the coffee machine, rather than solving the problem : /

Here is my configuration (created by ASDM)
: Saved
:
ASA Version 8.0(3)
!
hostname fw-datas-01
domain-name dataservice.no
enable password oqH5hJyrgO9HicO1 encrypted
names
name 10.70.1.0 OnlineBackup
name 10.69.201.13 AS400
name 10.1.1.0 OptikrtLEriksen
name 172.27.10.0 DS-IPsec-VPN-Pool
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.69.201.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 109.109.80.41 255.255.254.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name dataservice.no
object-group network DM_INLINE_NETWORK_1
 network-object 10.69.201.0 255.255.255.0
 network-object host AS400
access-list inside_access_in extended permit ip any any
access-list inside_access_in remark Svar paa PING
access-list inside_access_in extended permit icmp any any echo-reply
access-list inside_access_in remark Svar paa TRACEROUTE
access-list inside_access_in extended permit icmp any any time-exceeded
access-list inside_access_in extended deny ip any any
access-list outside_access_in remark Svar paa PING
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in remark Svar paa TRACEROUTE
access-list outside_access_in extended permit icmp any any time-exceeded
access-list outside_access_in extended permit ip DS-IPsec-VPN-Pool 255.255.255.0 10.69.201.0 255.255.255.0
access-list outside_access_in extended permit ip DS-IPsec-VPN-Pool 255.255.255.0 any
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended deny ip any any
access-list outside_1_cryptomap extended permit ip 10.69.201.0 255.255.255.0 OnlineBackup 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.69.201.0 255.255.255.0 OnlineBackup 255.255.255.0
access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 OptikrtLEriksen 255.255.255.0
access-list inside_nat0_outbound extended permit ip any DS-IPsec-VPN-Pool 255.255.255.0
access-list outside_2_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 OptikrtLEriksen 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool DS-IPsec-VPN-Pool 172.27.10.101-172.27.10.199 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 109.109.80.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.69.201.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 109.109.80.47
crypto map outside_map 1 set transform-set ESP-DES-MD5
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer 81.191.194.179
crypto map outside_map 2 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
group-policy DS-IPsec-VPN internal
group-policy DS-IPsec-VPN attributes
 dns-server value 10.69.201.10 94.139.66.254
 vpn-tunnel-protocol IPSec
 default-domain value kontor.dataservice.no
username dataservice password Sg0pz9n6pjAaipgX encrypted privilege 0
username dataservice attributes
 vpn-group-policy DS-IPsec-VPN
tunnel-group 109.109.80.47 type ipsec-l2l
tunnel-group 109.109.80.47 ipsec-attributes
 pre-shared-key *
tunnel-group 81.191.194.179 type ipsec-l2l
tunnel-group 81.191.194.179 ipsec-attributes
 pre-shared-key *
tunnel-group DS-IPsec-VPN type remote-access
tunnel-group DS-IPsec-VPN general-attributes
 address-pool DS-IPsec-VPN-Pool
 default-group-policy DS-IPsec-VPN
tunnel-group DS-IPsec-VPN ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:75f4caf3be14cc04c67dee4959c3a9be
: end
asdm image disk0:/asdm-603.bin
asdm location OnlineBackup 255.255.255.0 inside
asdm location OptikrtLEriksen 255.255.255.0 inside
asdm location AS400 255.255.255.255 inside
no asdm history enable
0
trondbotnen
Asked:
trondbotnen
1 Solution
 
DonbooCommented:
The reason you cant access the internet while connected id because you connect with a full tunnel with no special NAT settings.

You have 2 ways of giving VPN clients internet.

1. Configure split tunnel (less secure)
2. Configure VPN on a stick (most secure but bandwitdh consuming)


VPN on stick configuration link
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00805734ae.shtml

Split tunnel configuration link
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080702999.shtml
0
 
trondbotnenAuthor Commented:
This surly solved my problem!
Only thing I was missing, was that I HAD to have an inside interface selected, couldn’t be Inside/any.
But I would have realized this earlier, if I had bothered to read everything you sent me! :D

Thanks!
0

Featured Post

KuppingerCole Reviews AlgoSec in Executive Report

Leading analyst firm, KuppingerCole reviews AlgoSec's Security Policy Management Solution, and the security challenges faced by companies today in their Executive View report.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now