OS X certain apps repeated flash a "do you want to accept incoming connections" box

From time to time, an application when loaded will cause a dialog box to appear asking whether I want to allow or deny the application to accept network connections. The box disappears by itself in under one second, so it is hard to known even what it is asking, let alone respond to it.

The most annoying thing is that it is a mystery why the application should even be asking the question.

For example, the first application that started doing this was Photoshop Elements 6. It had been running for some time without doing this. Then one day, it started up doing it. It was so annoying that it practically prevented use of the program. Finally I got some advise that said to go into System Preferences > Security > Firewall and set "block incoming connections" for that application. This seemed to work, although the mystery was never explained.

Now the same issue started happening today with Firefox when I try to download a specific file. This is even more mysterious. What does it mean for Firefox to "accept network connections?" Is it not doing that constantly anyways? What is special about this download when compared against the thousands of downloads I have done before without this issue?

I tried the same solution by setting Firefox to "deny incoming connections" but in this case it had no effect. I am pretty sure that to get normal Firefox operation, I will have to unblock sooner or later.

Questions:

1. What is this confusing dialog box really trying to say?

2. Why does it constantly start appearing, then disappear in less than one second? IMHO, this is a bug, as it is not serving a function but just acting as a weird annoyance.

3. What is the proper fix?
jasimon9Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sigurdur ArmannssonDesigner Commented:
This sounds a bit like Little Snitch, a firewall application. Seems like its prefs are tuned on Auto Confirmation and minimal time to show the alert sign.

Pretty much useless if tuned this way.

Anyway, check if you find in Applications, Little Snitch Configuration. If it is there, open it up and tune it more to your liking.
0
Owen RubinConsultantCommented:
I can't help but wonder if you installed something you did not understand what it was installing?

Do you happen to have Little Snitch installed? That is a program that acts like a firewall and will ask you if you want to accept connections. Typically, it displays the request for some time, so I am wondering why this dialog is going away.

If installed, it MAY show two little bars of lines in the menu bar (in red and green) to show network activity, but that too could be disabled.

Go look in Applications and see if "Little Snitch Configurations" is there. You may be able to change the settings to something longer, although I thought it's automatic setting was 15 seconds or longer.

Also, you blocked incoming connections for Photoshop, you did not stop the dialog process, it just does not receive incoming messages.

If not little snitch, look for any other product you may have added that has firewall function.

Also, have you tried setting the internet firewall to allow all connections to see if IT is asking?

Lastly, do you use 1Password? It had some problems with this as well.
0
Owen RubinConsultantCommented:
Damn siguram, you got that answer in there as I was typing mine. You are fast!  :-)
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Sigurdur ArmannssonDesigner Commented:
I wrote fewer lines :D
0
jasimon9Author Commented:
Don't have Little Snitch. Nor anything installed that should be in this category.

But I do have 1Password. Seems this could be related. However, why would 1P interact with Photoshop Elements?

Do you have any more information on the 1P aspect, as a brief search did not find anything (searched on "1Password popup allow connect").

0
Owen RubinConsultantCommented:
I will have to get you the reference, don't have it here. But remember, 1Password holds passwords, and f an app us connecting to a web service that needs a login or password, it will go to 1password to get it.

I remember thus problem a while back. An app checks for updates or serial number or whatever, 1Password starts to pop up it's dialog asking if you want to connect using your stored info, then realizes it does not need "permission" and closes the dialog fairly quickly. That is why I asked you  about it. Are you using the latest version of 1P? Also, what version of the OS?  
0
Owen RubinConsultantCommented:
I cannot find the original reference, but have a look at this on 1Password. Not what I was looking for, but similar.

http://support.agilewebsolutions.com/showthread.php?14153-OS-X-Firewall-keeps-asking-to-accept-incoming-network-connections
0
reITmansCommented:
For my part, I wonder if you're using Snow Leopard as the operating system. If you have Snow Leopard, go to System Preferences, then Security. In the Security tab, not only check if the Firewall is on, but click the Advanced button. If you have the check mark Blocking all incoming connections, that might be the culprit.
0
jasimon9Author Commented:
orrubin: first, I dont' think this is a case of 1Password at all. Why would Photoshop interact with 1P?

Latest versions of software as I keep up-to-date: OS X 10.6.3; 1P 3.0.9
0
jasimon9Author Commented:
orrubin: I looked at the link you gave about the problem with 1Password. My immediate reaction is not that 1Password is the root cause of the problem -- it is that 1Password is yet another program that is experiencing the issue. The screen shots are showing the same thing as I have now seen for Photoshop and Firefox.

My conclusion: there is an underlying problem that affects various programs, and you are simply adding to the list of affected programs. Btw, I don't see it for 1Password. On my system, i see it for Photoshop and yesterday for Firefox.


0
jasimon9Author Commented:
reITMans: yes Snow Leopard, latest release 10.6.3. But it has been happening on earlier versions too. As stated in previous posts, it "seemed to fix it for Photoshop by changing the setting to block", but as pointed out by another user, that is merely hiding the effect, not fixing it.

For Firefox, setting either "block or accept" has no effect. In Firefox however, there is a major clue, in that it only happens when trying to download a file via the "Save Link As".
0
Owen RubinConsultantCommented:
Agreed.

However, if you read to the end of the post, they give some suggestions to fix it.

After reading that again, I might suggest a "repair permissions" as it is possible the "allow" is not sticking.

So, next suggestion: repair permissions.

After that, try removing Photoshop, and then re-adding it back.
0
Owen RubinConsultantCommented:
BTW: I mean remove Photoshop from the firewall, not from the computer, and then adding it back to the firewall. Just to be clear.
0
jasimon9Author Commented:
Thanks, maybe worth a try on repair permissions. And remove/re-add to firewall. Will let you know.
0
jasimon9Author Commented:
I did the repair permissions.

But I just noticed yet another program exhibiting the behavior: Adobe Reader, as soon as "Save As Copy" is choosen, while drilling down via Finder for a location to save the file, about once a second, the dialog pops up and immediately disappears, until the copy is saved.


0
Sigurdur ArmannssonDesigner Commented:
Would you be willing to open up Applications/Utilities/Activity Monitor and make a screenshot to upload for us? It might prove helpful to solve the case.
0
jasimon9Author Commented:
Ironically, during the upload process when I was selecting the file, the issue occurred for Firefox. I believe it is pretty consistent that it happens during the "open file" dialog.

This seems like something I could just search the web for, and I am going to.

Since I had to break the screen shot into two pieces it is possible that their might be a missing process which "fell between the screen shots."

Screen-shot-2010-04-08-at-5.32.1.png
Screen-shot-2010-04-08-at-5.33.0.png
0
Owen RubinConsultantCommented:
Have you been able to grab the EXACT text? Might help identify who.

Odd that saving to the disk is causing this to pop up. Is your iDsk mounted? I wonder if it is also exhibiting the problem.

Any chance you can screen grab the dialog?

This is an odd one.  Now, the other Adobe just tells us that when an Adobe program goes to the net to check for whatever it wants to check for, you get the dialog. Do you get the dialog if you open a web age to adobe?

Let me know how permissions and removing and replacing worked.
0
Owen RubinConsultantCommented:
I notice you are running Tunnelblick. I can't help but wonder if IT is putting up the dialog? According to a few things I have read, it does not work in Snow Leopard in 64-bit mode, so it may be causing some problems. Can you try disabling that and see if the problem goes away?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jasimon9Author Commented:
Summary: I wrote this response as I went through each of the suggestions, and am leaving my findings in place. However, the point #7 at the bottom gives the solution.

1. As reported above, we definitely have the "who" as it is in the message in the dialog box.

I remember capturing the text by watching the message appear over and over and getting a bit more of it each time, so I thought I had posted it here. However in checking above, I don't see it. I must have asked the question elsewhere. So I did that process again to get the message.

Here the message is, as best as I can reproduce it. Please note that in the blank, the name of the program appears, so that we definitely have a "who." So far that "who" has been either "Firefox.app", "Adobe Photoshop Elements 6.app", or "Adobe Reader.app".

Here is the message:

Do you want the application __________ to accept incoming network connections?

Clicking Deny may limit the application's behavior. This setting can be changed in the Firewall pane of Security preferences.

    Deny    Allow
2. iDsk - don't even know what that is. I don't use it.

3. Cannot screen grab, because it appears for less than one second.

4. The dialog does not occur when simply opening a web page. Only under certain "open file" and "save file" operations. For example, when trying to open a file in Photoshop, when trying to "Save Link As …"  in Firefox, or "Save as Copy" in Adobe Reader.

5. Repair Permissions had no effect.

6. Remove/replace of setting in firewall has no effect. In fact, I did the following, and rechecked the behavior after each step, and the issue was still present after each step. Steps:

 - observe current setting (Firefox blocked) to confirm issue;
 - remove Firefox from Firewall (still occurs)
 - add Firefox back to Firewall with "allow" (still occurs)
 - change Firefox to "deny" (still occurs)

7. Tunnelblick - this might be it! I turned it off, and the behavior seems to be corrected. However, it is more complex than simply Tunnelblick, as I have had the same version of that running for over a year, whereas the problem has only recently shown up. So probably something about Tunnelblick and a recent OS X upgrade I am guessing.

Btw, while shutting Tunnelblick down, there was an announcement of a new "stable" version, so after reloading the current version to confirm that the problem comes back, I am going to upgrade and see if that fixes the problem.

Actually, here is a strange result -- after shutting down Tunnelblick, the problem went away; but after restarting Tunnelblick, the problem stayed away. My conclusion is that somehow the Tunnelblick process got messed up a few weeks ago and has been causing this problem since.

So the workaround when this problem occurs -- restart Tunnelblick.

However, this may only be coincidence, and would not be confirmed until such future time as the problem recurs, and restarting Tunnelblick fixes it. Which could be a moot point if the new version of Tunnelblick also solves the problem.

In any case, the Tunnelblick suggestion seems to be the solution at this time, and points are due.






0
jasimon9Author Commented:
Immediate apparent workaround is to restart Tunnelblick, as after such a restart, the problem no longer appears.

Will also upgrade Tunnelblick to the new "stable" version.

My final long post is a pretty good documentation of the symptoms, so it could be useful to someone.
0
Owen RubinConsultantCommented:
Excellent. Dumping your running tasks was a great idea (thanks sigurarm) because it let me see what else was running, and I had read the Tunnelblick was causing problems in Snow Leopard.

Hope that is the final fix. Cheers, and thanks for the score.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.