Turn off dialog boxes in gvim

I have been using vi/vim/gvim for a few months now, and am loving it.  However, I recently discovered an annoyance while using gvim.  I will often start a bash shell from within gvim so that I can use our versioning-control software to either check a file in or out.  However, this means that when I exit the bash shell, gvim senses the change in the file permissions, and pops up a dialog box notifying me that the file has changed, and allowing me to either dismiss the message or re-load the file.  I always reload the file, but I find that it requires me to move from the keyboard to my mouse and click the "load file" button.

My question is this:  is there a setting in gvim that will make all those notifications in-line like it would be in the non-gui vim?  I want to have no windowed dialog boxes, because they require me to switch to the mouse.  I just want it to prompt me in the command/status bar at the bottom, and then I can type my response without ever leaving my beloved home-row.

Thanks in advance!
LVL 3
crakdmirrorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tty2Commented:
From Vim FAQ:

5.6. When editing a file in Vim, which is being changed by an external
     application, Vim opens a warning window (like the confirm dialog) each
     time a change is detected. How do I disable this warning?

You can set the 'autoread' option to configure Vim to automatically read
the file again when it is changed outside of Vim:

    :set autoread

You can also use the following autocommand:

    autocmd FileChangedShell *
          \ echohl WarningMsg |
          \ echo "File has been changed outside of vim." |
          \ echohl None

For more information, read

    :help 'autoread'
    :help FileChangedShell
    :help timestamp
    :help :checktime

http://vimdoc.sourceforge.net/cgi-bin/vimfaq2html3.pl
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crakdmirrorAuthor Commented:
Perfect!  Autoread was exactly what I was looking for!  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.