• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 392
  • Last Modified:

How do i fix OWA? It will not load

Recently setup OWA and had everything working great as an independant site (https://domain/owa). I decided to work on getting RWW functional, and after changing certificate settings, listener settings  in Forefront TMG and authorization settings in IIS, OWA no longer works correctly.

I can still access the OWA login page, but when I enter my credentials and click Log On, it just sits there trying to load infinitely...

I tried deleting and recreating the virtual directories in IIS, changed all auth settings back to what I "think" is right, and I took the TMG server out of the picture (shut it down until I get OWA back  to working good). I have had nothing but problems with the Security Server portion of Essential Business Server 2008. It causes hiccups with everything it seems. I leave it shut down and just use my existing firewall.

I am looking for some Exchange OWA experts to help me work through this. Then It's on to RWW if I can get the Forefront TMG to stop causing trouble. (I already have sharepoint services accessible via the internet as well). Both sharepoint and OWA use public SSL certs.
1 Solution
I have done the EXACT same thing as you. I am really really sorry and I hate to tell you this because I wish there had been answer when I was in the same place but Forefront TMG totally messes up Exchange if you don't get it professionally done. The BEST thing to do is to do a fresh install. I know its not pretty, but now that your at the point of redoing directories - your extremely likely to start making mistakes that will cost you serious time later.

My recommendation, don't use TMG unless you MUST and if you do, get a pro to set it up. Exchange is protected really well as is on a Windows 2k8 machine.

Best wishes,, hope this helps!
CoSmismgrAuthor Commented:
I had HTTP redirect enabled in a few different directories. I disabled all of them and accessed OWA by typing in the full address and it worked fine.

So now I am wondering... what is the best method to redirect requests for http://server to https://server/owa?

I know I can just enable HTTP redirect on Default Web Site to /owa but that would mean ALL requests to that server would be redirected to /owa.... I plan to use RWW soon, and need to be able to resolve to the /remote directory as well. Should/can I move the /remote site to another server to get around this?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now