No Remote Desktop to XP SP3 Machine

I have a new XP computer running SP3 that will not allow Remote Desktop connections to it.  It is a member of an SBS 2003 domain.  I can remote desktop into other computers from the machine in question but I can't get into this machine.  I've done the following:

1. Made Sure that Remote Desktop is enabled from System Properties > Remote
2. Turned Windows Firewall Off on the local computer
3. I have gone in and changed the default protocol to 23389. (I didn't confirm that it RD worked before I made this change but it didn't work when I set the default port back to 3389).
4. I can telnet to the XP SP3 machine from other computers in the local network on port 23389 and it appears to start a session with a blinking cursor.
5. When I try to RDP to this computer using the computer name or the static IP address the RDP program comes back to the original screen with no error message.
6. I've checked to make sure that terminal services is running in the services window.

At this point the only options that I'm coming up with are to try to restore the computer to an earlier point in time (basically a "Hail Mary" pass) or reinstall Windows.  I would like to avoid both of those options if possible.   Finally, one item of note, this computer also has Spector 360 server installed on it along with logmein.  Neither of these programs seem to be causing any trouble.

Thanks for your help!
LVL 4
kdubendorfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

B HCommented:
did you reboot after you changed the default port?

can you get this, fire it up and see what's listening on which ports?  (post a screenshot if you want)

http://live.sysinternals.com/Tcpview.exe
0
B HCommented:
oh a few more things - are there any firewalls between that machine and the one you're connecting from?

when connecting to it, are you using the format of:
computername:23389
?

0
kdubendorfAuthor Commented:
Yes I did reboot after making the change.  Here's the result of the Sys Internals Run:
[System Process]:0      TCP      karl001.arose.local:1440      arosesvr.arose.local:1026      TIME_WAIT      
[System Process]:0      TCP      karl001.arose.local:1439      arosesvr.arose.local:epmap      TIME_WAIT      
[System Process]:0      TCP      KARL001:1421      localhost:5152      TIME_WAIT      
alg.exe:3816      TCP      KARL001:1181      KARL001:0      LISTENING      
Dell.UCM.exe:3296      TCP      KARL001:1157      localhost:3979      ESTABLISHED      
IEXPLORE.EXE:3116      UDP      KARL001:1358      *:*            
IEXPLORE.EXE:6076      TCP      KARL001:1473      localhost:5152      FIN_WAIT2      
IEXPLORE.EXE:6076      UDP      KARL001:1420      *:*            
jqs.exe:1952      TCP      KARL001:5152      localhost:1473      CLOSE_WAIT      
jqs.exe:1952      TCP      KARL001:5152      KARL001:0      LISTENING      
lms.exe:344      TCP      KARL001:1038      localhost:1037      ESTABLISHED      
lms.exe:344      TCP      KARL001:1037      localhost:1038      ESTABLISHED      
lms.exe:344      TCP      KARL001:16993      KARL001:0      LISTENING      
lms.exe:344      TCP      KARL001:664      KARL001:0      LISTENING      
LogMeIn.exe:440      TCP      karl001.arose.local:1040      app03.logmeinrescue-enterprise.com:https      ESTABLISHED      
LogMeIn.exe:440      TCP      KARL001:2002      localhost:1154      ESTABLISHED      
LogMeIn.exe:440      TCP      KARL001:2002      KARL001:0      LISTENING      
LogMeInSystray.exe:2780      TCP      KARL001:1154      localhost:2002      ESTABLISHED      
lsass.exe:800      UDP      KARL001:isakmp      *:*            
lsass.exe:800      UDP      KARL001:1026      *:*            
lsass.exe:800      UDP      KARL001:4500      *:*            
lsass.exe:800      TCP      karl001.arose.local:1477      arosesvr.arose.local:1026      ESTABLISHED      
lsass.exe:800      TCP      karl001.arose.local:1476      arosesvr.arose.local:epmap      ESTABLISHED      
SMManager.exe:1704      TCP      KARL001:3979      localhost:1157      ESTABLISHED      
SMManager.exe:1704      TCP      KARL001:3979      localhost:1039      ESTABLISHED      
SMManager.exe:1704      TCP      KARL001:1039      localhost:3979      ESTABLISHED      
SMManager.exe:1704      TCP      KARL001:3979      KARL001:0      LISTENING      
SPCEAdminSvc.exe:308      TCP      KARL001:16768      KARL001:0      LISTENING      
SPCEAdminSvc.exe:308      UDP      KARL001:16768      *:*            
SPDataServer.exe:328      TCP      karl001.arose.local:1113      karl001.arose.local:1299      ESTABLISHED      
SPDataServer.exe:328      TCP      KARL001:16769      KARL001:0      LISTENING      
SPLicenseManager.exe:684      TCP      KARL001:16770      KARL001:0      LISTENING      
SPWebFilterSvr.exe:1136      TCP      KARL001:16771      KARL001:0      LISTENING      
SPWebFilterSvr.exe:1136      UDP      KARL001:16771      *:*            
SqlAgentService.exe:500      TCP      karl001.arose.local:1414      karl001.arose.local:1299      ESTABLISHED      
SqlAgentService.exe:500      TCP      karl001.arose.local:1415      karl001.arose.local:1299      ESTABLISHED      
SqlAgentService.exe:500      TCP      karl001.arose.local:1416      karl001.arose.local:1299      ESTABLISHED      
SqlAgentService.exe:500      TCP      karl001.arose.local:1417      karl001.arose.local:1299      ESTABLISHED      
SqlAgentService.exe:500      TCP      karl001.arose.local:1418      karl001.arose.local:1299      ESTABLISHED      
SqlAgentService.exe:500      TCP      karl001.arose.local:1419      karl001.arose.local:1299      ESTABLISHED      
sqlbrowser.exe:1848      UDP      KARL001:ms-sql-m      *:*            
sqlservr.exe:604      TCP      karl001.arose.local:1299      karl001.arose.local:1414      ESTABLISHED      
sqlservr.exe:604      TCP      karl001.arose.local:1299      karl001.arose.local:1415      ESTABLISHED      
sqlservr.exe:604      TCP      karl001.arose.local:1299      karl001.arose.local:1416      ESTABLISHED      
sqlservr.exe:604      TCP      karl001.arose.local:1299      karl001.arose.local:1417      ESTABLISHED      
sqlservr.exe:604      TCP      karl001.arose.local:1299      karl001.arose.local:1418      ESTABLISHED      
sqlservr.exe:604      TCP      KARL001:1299      KARL001:0      LISTENING      
svchost.exe:1064      TCP      KARL001:epmap      KARL001:0      LISTENING      
svchost.exe:1152      UDP      karl001.arose.local:ntp      *:*            
svchost.exe:1152      UDP      KARL001:ntp      *:*            
svchost.exe:1152      TCP      karl001.arose.local:1475      arosesvr.arose.local:8530      ESTABLISHED      
svchost.exe:1312      UDP      karl001.arose.local:1900      *:*            
svchost.exe:1312      UDP      KARL001:1900      *:*            
svchost.exe:996      TCP      KARL001:23389      KARL001:0      LISTENING      
System:4      TCP      karl001.arose.local:1138      arosesvr.arose.local:microsoft-ds      ESTABLISHED      
System:4      TCP      KARL001:microsoft-ds      KARL001:0      LISTENING      
System:4      TCP      karl001.arose.local:netbios-ssn      KARL001:0      LISTENING      
System:4      UDP      karl001.arose.local:netbios-ns      *:*            
System:4      UDP      KARL001:microsoft-ds      *:*            
System:4      UDP      karl001.arose.local:netbios-dgm      *:*            
UNS.exe:2168      TCP      KARL001:1069      KARL001:0      LISTENING      
winlogon.exe:744      UDP      KARL001:1073      *:*            
wltuser.exe:3556      UDP      KARL001:1356      *:*            
wmiprvse.exe:1208      UDP      KARL001:1083      *:*            
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

kdubendorfAuthor Commented:
Yes, when connectiong I am using the format:  10.1.1.222:23389 or karl001:23389.
0
B HCommented:
can you try from the xp machine itself, remote desktop two times for testing, one of each:

localhost
localhost:23389

and tell the results of each - you should get error messages, the content of those messages are important
0
kdubendorfAuthor Commented:
Localhost yields:
The computer cann't connect to the remote computer.  Try connecting again.  If the problem continues, contact the owner of the remote computer or the network adminsitrator.

Localhost:23389 yields:
The client could not connect.  You are already connected to the console of this computer.  A new console session cannot be established.

Pretty much what I would expect but still no remote connection.   It's not looking good
0
B HCommented:
right, that wasn't supposed to fix anything, but it confirmed the tcpview that your xp machine is fully expecting connections on 23389, and that the terminal services on it are functioning how they should be

so - what's stopping the other machine from getting to it...  how about the firewall settings on the machine you're connecting from?

can you connect from a different machine, to this 23389 one?

are there any hardware firewalls or routers between the machine you're coming from, and this 23389 one?
0
JohnLoCommented:
Localhost:23389 This is GOOD!!! Means RDP is running on the machine on 23389 now we just have to figure out what is causing it not to connect...

Im booting up a Virtual XP machine to play with it now...
0
kdubendorfAuthor Commented:
Bryon, there are no routers between machines.  I get the same result wheter or not I have the firewall on in the originating system.   Again the firewall in the 23389 computer is turned off.

I get the same result no matter what machine I come from heading to the 23389 machine.  They all return to the original RDP screen almost immediately with no error message.

thanks for trying John
0
B HCommented:
would you be willing to try a different port, say 3390 for example?  something not as high maybe?
0
kdubendorfAuthor Commented:
I'm on my forth port now....including trying to switch back to 3389.   Changing the port unfortunately doesn't seem to make any difference.
0
JohnLoCommented:
I just confirmed in my lab that he should be fine on 23389. worked fine in my VM lab on a XP machine.
0
JohnLoCommented:
What do you mean exactly when you say "RDP program comes back to the original screen with no error message"?
0
kdubendorfAuthor Commented:
It's as though I don't hit the connect button.   You can see the computer tries to connect via Remote Desktop Connection when you press connect....the window kind of flickers ....then you're back at the original Remote Desktop Connection screen.  No message...no connection.
0
JohnLoCommented:
ok just read something about this did you recently update your video driver? I saw this same result on another site when they recently updated thier nvidia video driver...

Can you try rolling back the driver rebooting and trying again?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
B HCommented:
ok so fire up tcpview again.. and watch the line that includes 23389 and "listening"...  when you try to connect from the other machine, does it or anything else turn green?

this will tell us if you're even getting to the xp machine, or if you're being prevented from even leaving the machine connecting from

0
kdubendorfAuthor Commented:
I didn't update my video driver at all so there's nothing to roll back to.   But on that note I did see that it was out of date.   I just downloaded the latest Nvidia Geoforce 9300 driver (December 2009).

It worked!!!!!!!   I am now able to connect to the computer via RDP.   Thank you both, John you are the man!

Never would have guessed that the video driver was the issue.   Another case where a computer reload would have been a waste of time.   Thank you.  Thank you!!!
0
JohnLoCommented:
NP bryon got me on the right track.... he deserves half!
0
kdubendorfAuthor Commented:
John came through with the clue that ultimately solved the problem.   Bryon stuck with me throughout and did help me confirm that everything was setup properly.

I awarded the lion's share of the points to John since he pointed me in the right direction.

Thank you to both of you.
0
kdubendorfAuthor Commented:
Fair enough.   Not sure if I can change it at this point.  Next time I'll discuss it before i post it.   Any suggestions as to how I can realocate?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.