InnoDB: Error: cannot allocate 536887296 bytes of memory with malloc!

Hi running Windows Server 2003 EE 4GB memory with 2CPU.

Has MYSQL 5.1 community version installation.  Database is running very slow so I have
tried increasing the innodb_buffer_pool_size from 256M to 1G which failed then 512M which
also failed both with the same error.

100408 14:05:13  InnoDB: Error: cannot allocate 536887296 bytes of
InnoDB: memory with malloc! Total allocated memory
InnoDB: by InnoDB 7725316 bytes. Operating system errno: 8
InnoDB: Check if you should increase the swap file or
InnoDB: ulimits of your operating system.
InnoDB: On FreeBSD check you have compiled the OS with
InnoDB: a big enough maximum process size.
InnoDB: Note that in most 32-bit computers the process
InnoDB: memory space is limited to 2 GB or 4 GB.
InnoDB: We keep retrying the allocation for 60 seconds...
InnoDB: Fatal error: cannot allocate the memory for the buffer pool
100408 14:06:13 [ERROR] Plugin 'InnoDB' init function returned error.
100408 14:06:13 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
100408 14:06:13 [ERROR] Unknown/unsupported table type: INNODB
100408 14:06:13 [ERROR] Aborting

100408 14:06:13 [Warning] Forcing shutdown of 1 plugins
100408 14:06:13 [Note] D:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown
complete

Have tried reducing the number of maximum connection from 800 to 100 but this made no
difference.  Still getting the same error.

Also tried adding the /3GB switch in the boot.ini but made no differnce.

Any help would be greatly appreciated.  Have attached the my.ini file

Thanks in advance.




my.ini
johng33Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johng33Author Commented:
Have resolved it.  Was running MYSQL 5.1.31 updated to 5.1.45 and now able to increase the innodb_buffer_pool_size
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.