Missing workflow metadata from SharePoint document library

I have a basic document library using the basic "approval" workflow out of the box in SharePoint. It seems some of the metadata from the workflows stating that the document has been approved seems to be missing. As far as I know, nothing is being deleted. I included a screen shot and hopefully that help explain what I'm talking about. Hopefully I can post some more information tomorrow once I gather some more details.
Noname1.jpg
DxtrLwsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

irinucCommented:
Not entirelly sure if this is the issue you're seeing, however, here is an information that may explain why some metadata is missing: by default settings, older than 30 days completed workflows are purged for performance reasons. The history of these workflows is kept in the History List that was setup when workflow was created.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DxtrLwsAuthor Commented:
I had no clue that it got purged from the system after a while. I believe that's what is happening here. Looks like the "History List" also gets purged as well. Is there way to permanently keep the workflow metatdata, either in the current document library or in another custom list?
0
irinucCommented:
Actually, I do not believe the History list is purged; at least I was able to find there all the items since months ago. It is however a bit complicated to relate the item to the history (as they are linked on item ID and list ID) and sometimes to find the list. If you use the default settings, the list is hidden - not showing on the browser - need to navigate directly to it: http://URL_TO_YOUR_SITE/Lists/workflow%20history/AllItems.aspx

Here is a link to a blog where you may find some ideas on how to stop the timer job or to view the history in a user-friendly way:
http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/b15b27e2-3033-418b-9731-968273d7423e/
In this blog they say the interval is 60 days, so I may have been wrong on that. Sorry.

Hope this helps
0
DxtrLwsAuthor Commented:
Thanks for you help and quick response. This was very helpful!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.