How can I completely disable Exchange 2007 default spam- / contentfiltering?

We have a standard third party antispam solution for our email. We do not want anything else scanning the mail and perhaps blocking email. The problem now is that we often get this message:

srv-001.DMN-ELISYS #5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by Remote Host

I thing there is some filtering enabled, there is nothing configured on user level or default Exchange lever for maximum size, so I do not understand wat causes this message.
AgrippaSenior IT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
This is to do with size limits is srv-001.DMN-ELISYS your exchange server?
0
SteveIT ManagerCommented:
0
AgrippaSenior IT ConsultantAuthor Commented:
Hi Dematzer,

no DMN-ELISYS is the sending server (our server), it is not the server of the receipient.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

AgrippaSenior IT ConsultantAuthor Commented:
Hello SQSM81,

tried that already, but still receiving the message size error.
0
Glen KnightCommented:
Then what ever server that server is sending to has a 10MB size limit.  What does that send to? Is it a SPAM appliance?
0
AgrippaSenior IT ConsultantAuthor Commented:
We are sending from an Exchange 2003 to an Exchange 2007. Never had this problem with a 2003.
0
Glen KnightCommented:
Can you run the following commands on the Exchange 2007 server in the Exchange Management Shell and post the results:

Get-TransportConfig

Get-ReceiveConnector | fl

Get-SendConnector | fl


0
AgrippaSenior IT ConsultantAuthor Commented:
Hello Dematzer,

how can ik make an output to a file, there is to much information and i cannot do a copy paste.
0
Glen KnightCommented:
You should be able to add > c:\output1.txt on the end of the command.

Just remember to change the number after each command.
0
AgrippaSenior IT ConsultantAuthor Commented:
Hello Demazter:

Get-TransportConfig

ClearCategories : True
DSNConversionMode : UseExchangeDSNs
GenerateCopyOfDSNFor : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers : {127.0.0.1}
JournalingReportNdrTo : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime : 7.00:00:00
MaxReceiveSize : unlimited
MaxRecipientEnvelopeLimit : 5000
MaxSendSize : unlimited
TLSReceiveDomainSecureList : {}
TLSSendDomainSecureList : {}
VerifySecureSubmitEnabled : False
VoicemailJournalingEnabled : True
WritingBrandingInDSNEnabled : True
Xexch50Enabled : True
Get-ReceiveConnector | fl
AuthMechanism                           : Tls, Integrated, BasicAuth, ExchangeS
                                          erver
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {192.168.0.1:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : SRV-001.dmn-nepak.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 20240KB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000
PermissionGroups                        : ExchangeUsers, ExchangeServers, Excha
                                          ngeLegacyServers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {192.168.0.255-192.168.0.255, 192.168
                                          .0.0-192.168.0.253}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : SRV-001
SizeEnabled                             : EnabledWithoutValue
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Default SRV-001
DistinguishedName                       : CN=Default SRV-001,CN=SMTP Receive Co
                                          nnectors,CN=Protocols,CN=SRV-001,CN=S
                                          ervers,CN=Exchange Administrative Gro
                                          up (FYDIBOHF23SPDLT),CN=Administrativ
                                          e Groups,CN=First Organization,CN=Mic
                                          rosoft Exchange,CN=Services,CN=Config
                                          uration,DC=dmn-nepak,DC=local
Identity                                : SRV-001\Default SRV-001
Guid                                    : 4edc48b8-343c-4c46-b3fe-8612e15b16b6
ObjectCategory                          : dmn-nepak.local/Configuration/Schema/
                                          ms-Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 21-3-2010 20:55:17
WhenCreated                             : 29-11-2009 18:24:22
OriginatingServer                       : SRV-001.dmn-nepak.local
IsValid                                 : True
AuthMechanism                           : BasicAuth
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {127.0.0.1:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : SRV-001.dmn-nepak.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 06:00:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 20240KB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 200
PermissionGroups                        : AnonymousUsers, ExchangeUsers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {127.0.0.1-127.0.0.1}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : SRV-001
SizeEnabled                             : Enabled
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Windows SBS Fax Sharepoint Receive SR
                                          V-001
DistinguishedName                       : CN=Windows SBS Fax Sharepoint Receive
                                           SRV-001,CN=SMTP Receive Connectors,C
                                          N=Protocols,CN=SRV-001,CN=Servers,CN=
                                          Exchange Administrative Group (FYDIBO
                                          HF23SPDLT),CN=Administrative Groups,C
                                          N=First Organization,CN=Microsoft Exc
                                          hange,CN=Services,CN=Configuration,DC
                                          =dmn-nepak,DC=local
Identity                                : SRV-001\Windows SBS Fax Sharepoint Re
                                          ceive SRV-001
Guid                                    : 3df2ffe9-f89d-423b-9dcf-ca1a4a0fac85
ObjectCategory                          : dmn-nepak.local/Configuration/Schema/
                                          ms-Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 21-3-2010 20:57:24
WhenCreated                             : 29-11-2009 18:28:56
OriginatingServer                       : SRV-001.dmn-nepak.local
IsValid                                 : True
AuthMechanism                           : Tls
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {192.168.0.1:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
Fqdn                                    : remote.nepak.nl
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:01:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 20240KB
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 200
PermissionGroups                        : AnonymousUsers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {192.168.1.0-255.255.255.255, 192.168
                                          .0.254-192.168.0.254, 0.0.0.0-192.167
                                          .255.255}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
Server                                  : SRV-001
SizeEnabled                             : Enabled
TarpitInterval                          : 00:00:05
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Windows SBS Internet Receive SRV-001
DistinguishedName                       : CN=Windows SBS Internet Receive SRV-0
                                          01,CN=SMTP Receive Connectors,CN=Prot
                                          ocols,CN=SRV-001,CN=Servers,CN=Exchan
                                          ge Administrative Group (FYDIBOHF23SP
                                          DLT),CN=Administrative Groups,CN=Firs
                                          t Organization,CN=Microsoft Exchange,
                                          CN=Services,CN=Configuration,DC=dmn-n
                                          epak,DC=local
Identity                                : SRV-001\Windows SBS Internet Receive
                                          SRV-001
Guid                                    : 7cbda828-e4af-4342-9292-5a715476d881
ObjectCategory                          : dmn-nepak.local/Configuration/Schema/
                                          ms-Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 21-3-2010 20:57:54
WhenCreated                             : 13-1-2010 12:43:09
OriginatingServer                       : SRV-001.dmn-nepak.local
IsValid                                 : True

Get-SendConnector | fl

AddressSpaces                : {smtp:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : False
DomainSecureEnabled          : False
Enabled                      : True
ForceHELO                    : False
Fqdn                         : remote.nepak.nl
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SRV-001
Identity                     : Windows SBS Internet Send SRV-001
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10MB
Name                         : Windows SBS Internet Send SRV-001
Port                         : 25
ProtocolLoggingLevel         : None
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {smtp.routit.net}
SmartHostsString             : smtp.routit.net
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SRV-001}
UseExternalDNSServersEnabled : False
0
Glen KnightCommented:
Your send connector has a 10MB limit on it:

MaxMessageSize               : 10MB

run the following command:


Set-SendConnector –Identity "Windows SBS Internet Send SRV-001" -MaxMessageSize 20MB

this will set the limit to 20MB which is the same as your receive connector.
0
AgrippaSenior IT ConsultantAuthor Commented:
Hi Dematzer,

I have done this, but still it give this error:

<srv-001.DMN-ELISYS #5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by Remote Host>

Is says: REMOTE HOST, so the problem is not "our" server on which we have set this: Set-SendConnector –Identity "Windows SBS Internet Send SRV-001" -MaxMessageSize 20MB

Perhaps I need to put in a command on the receiving server for the receiving limitation?
0
Glen KnightCommented:
It's more likely to be the server you are sending to so changing the limits on your server won't help but that send connector setting wouldn't have helped either.

Do you only get that when sending to certain recipients?
0
AgrippaSenior IT ConsultantAuthor Commented:
We have a little miscommunication I'm afraid. The information from the GET commands are from the SENDING server. The command you gave me I have applied that on the sending server. So if you can tell me what needs to be changed on the receiving server I will try that.
0
Glen KnightCommented:
Can you run the commands onthe RECEIVING server then please?
0
AgrippaSenior IT ConsultantAuthor Commented:
Sorry sorry Demazter, I am making a dumb mistake. Those WHERE from the receiving server, but the COMMAND you gave me was for the SEND connector while my problem is the RECEIVING part.
0
Glen KnightCommented:
The receive connector is set to 20240kb according to the outputs above
0
AgrippaSenior IT ConsultantAuthor Commented:
Exactly, and that is why I put this question in Experts Exchange, because despite of all setting which all seem correct we still have this error.
0
Glen KnightCommented:
Do you send your mail via a smarthost or directly via DNS?
0
Glen KnightCommented:
The error is generated because of a REMOTE host.
This is not your exchange server.

Do you send your email via a smarthost?
A SPAM appliance?
Do you have antivirus/SPAM software installed?
Do you get this message for all recipients or are there some you can send 10MB files to?

Can you send me a 10mb message to either glen @ gkitsolutions.co.uk or glen.knight @ gpisolutions.co.uk (I am not sure the first one will accept it or not)
0
AgrippaSenior IT ConsultantAuthor Commented:
We send mail through a smart host, also get the same error when sending the large email tot your addresses.
0
Glen KnightCommented:
If you send to a smart host can you check they don't have a 10mb limit?

You can do this by telnetting to it on port 25 and then type ehlo
this will provide the size limit.

If you paste the output I can have a look for you
0
AgrippaSenior IT ConsultantAuthor Commented:
I Receive : Syntactically invalid EHLO argument(s)
0
Glen KnightCommented:
I would suggest getting in touch with who ever controls the smarthost to confirm they do not have a restriction in place
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Glen KnightCommented:
Also doyou haveany SPAMor virus software on the server?
If so can you uninstall it to remove that as being the problem
0
Glen KnightCommented:
What was it?
0
AgrippaSenior IT ConsultantAuthor Commented:
By testing different Exchange servers on differtent ISP's and therefore different smart hosts, if becomes clear that most ISP's have a limit of their own and send out the same error message. It was not an Exchange limit, but ISP limit.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.