Opening .wri files in Word 2007?

Hi,

One of my users needs to open a .WRI file in Word 2007 (or at least convert it to something readable) but he gets an error indicating that some converter program (write32.upc) is missing? I got the same on my machine where the whole of Office 2007 is installed.

So is there a way to make these ancient files readable again? It still worked with Word 2003.

Thank you!
XeronimoAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
I think that your only choice is to find a machine that has WinME or older because the security update to block 'wri' files applies to everything after that.
0
 
wobbledCommented:
In theory Word 2007 will open these, but just checking on google this doesn't seem to be the case.  As the WRI format was a predecessor to word pad.  Try opening these files using the Windows WordPad option and then just saving them in the standard word pad format.  They should then open fine in Word
0
 
XeronimoAuthor Commented:
Opening them in Wordpad results in gibberish and lots of weird signs though ... ?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Dave BaldwinFixer of ProblemsCommented:
It's Write32.wpc.  According to this Microsoft page, it is blocked for security reasons. http://support.microsoft.com/kb/973904  I think it also says you can allow it thru registry changes.  You could find an old machine to convert them to something readable.
0
 
XeronimoAuthor Commented:
Dave:

Thanks. I've run the FixIt thing but it still doesn't work and still tells me that the write32.wpc is missing ...

As for the second registry change, I can't find this one: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Applets\Wordpad

'Wordpas' is missing under 'applets' in my case. Should I create it manually?

0
 
XeronimoAuthor Commented:
Why WinME? It worked on a Windows XP (with Office 2003) before ...

Thanks.
0
 
Dave BaldwinFixer of ProblemsCommented:
But it is not supposed to anymore because of a Microsoft Security update I mentioned above that blocks it on Windows 2000 or newer.  The date of the update is December 8, 2009.
0
 
XeronimoAuthor Commented:
Ok, weird. But thanks for your help then!
0
 
Dave BaldwinFixer of ProblemsCommented:
Thanks for the points.  Companies are always making things obselete, partly because they need to sell new things and parly because they can't afford to support the old things anymore.  I know it's expensive to try to keep up but we have to do it sometimes.  Or keep a lot of old computers around...
0
All Courses

From novice to tech pro — start learning today.