SCCM Reporting does not work after changing security in IIS

Hi all,

After changing the Directory Security on the Default Website in IIS (trying to enable SSO) it seems now my reports do not run at all anymore.

I get different errors ranging from
The call to Server.CreateObject failed while checking permissions. Access is denied to this object.
to
Report (xx) is unavailable. Either you do not have permissions to view the report or the report does not exist.

I have tried already adjusting the dcomfig security as advised in other solutions, but that made no difference.

I know I caused it myself by changing the Security, no the problem is how to revert back to the original situation......

Can someone maybe guide me on which settings should be set on the Security of the default website and any node if they differ from the parent?
scstechteamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rem-8Commented:
Yeah, changing security in IIS in case of having those System Center packets with reporting is horrible (the same happens in SCOM). Try running Reporting Configuration Wizard again and add there accounts on which SCCM is running. Second thing which comes on my mind is to del/inst Reporting Role from SCCM console.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
scstechteamAuthor Commented:
I already went through the config wizard for the reporting role again, but that did not seem to solve the problem.

What did solve the problem was actually just deleteing the reporting role and adding it again. tnx!
0
scstechteamAuthor Commented:
It seems that there are more roles impacted by this security issue. When trying to deploy a package it always ends with error 1619. In the same manner I tried deleting the DP and installing it again, but this time it seems it did not do the trick.... any advise?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.