MySQL Server Wont Start!!! (UBUNTU)

Hey all,

I'm a complete n00b when it comes to linux administration, however I've had an ubuntu distro running now for about 2 months with no probs (PHP, Apache2, MySQL). Then yesterday i tried to install and configure an MTA and MTU (Which didn't work) but since then MySQL server has stopped working and I have no idea why, I've got WebMin installed and that says "MySQL is not running on your system - database list could not be retrieved." PHPMyAdmin says "#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)". Iv'e tried restarting manually with /etc/init.d/mysql start with no avail. Just completely stumped!
LVL 1
aarmstr2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cjl7freelance for hireCommented:
When you try to start the mysql-server does the syslog report any errors?

Also when you start it with /etc/init.d/mysql start - what happens?

//jonas
aarmstr2Author Commented:
How would i check the syslog? mysql.log and mysql.err are empty. When i run /etc/init.d/mysql start nothing happens at all.
samriCommented:
hi,

The mysql log would be in /var/log/mysqld.log (on Centos5.4)

check your /etc/my.cnf for any clue.  The default on centos is

[root@loaclhost log]# more /etc/my.cnf
[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).
old_passwords=1
[mysql.server]
user=ysql
basedir=/var/lib

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
[root@localhost log]#


I found some detailed info on this link.
http://fak3r.com/2009/02/18/howto-configure-mysqls-mycnf-fil/

cheers,
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

cjl7freelance for hireCommented:
does 'ps -ef |grep mysql' show anything?

how about a 'service mysql restart'

Are you running SELinux ('sestatus')

//jonas
aarmstr2Author Commented:
ps -ef |grep mysql returns '5390  4722  0 11:45 pts/0    00:00:00 grep mysql', service mysql restart did nothing. samri, cnf and log eother do not exist in that location or are empty. SE Linux is disabled.
PazHRCCommented:
try to do the most simple thing:
$ sudo apt-get remove --purge mysql
$ sudo apt-get install mysql

i'm sure who after this mysql will work

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aarmstr2Author Commented:
wont that delete my databases too?
aarmstr2Author Commented:
Tried that anyways, it says 'E: Couldn't find package mysql'
cjl7freelance for hireCommented:
mysql-server
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.