[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 861
  • Last Modified:

Exchange 2003 w/ Iphone setup

Pulling my hair out trying to get my Iphone to sync with my exchange 2003 sp2 (patched up to date) server.  I initially had certificate issues, but think I fixed those with a godaddy cert.  When I run https://www.testexchangeconnectivity.com everything comes back successful now, the only warning I get is:

Validating certificate trust for Windows Mobile Devices
  The test passed with some warnings encountered. Please expand additional details.
   Additional Details
  Certificate is only trusted on Windows Mobile 6.0 and later. Windows Mobile 5.0 and 5.0 + MSFP devices will not be able to sync. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US  
 
I wouldn't think this would be a show stopper.  

When I run accessmylan activesync tester on the iphone the results show:

checking connection... OK
Checking Certificate... OK
Checking Application... FAIL

Activesync is NOT available.
(ActiveSync is NOT available on this server.)

I can get to mail.domain.com/exchange-oma fine using my Iphone browser..

Is there a firewall port I need to open?  What else can I look at?  I tried setting up the mail account on the phone regardless of the accessmylan results, but it comes back Exchange Account Verification Failed.

Help Please!!
0
H2Omike
Asked:
H2Omike
  • 7
  • 6
1 Solution
 
Alan HardistyCo-OwnerCommented:
Please have a read through my Exchange 2003 / Activesync article and check your permissions under IIS and then if you get stuck, shout:
http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Exchange-2003-Activesync-Connection-Problems-FAQ.html 
0
 
H2OmikeIT ManagerAuthor Commented:
Got to ASP.NET Version.. it's set to 2.0.50727 and is greyed out.  How do I change it to 1.1?
0
 
Alan HardistyCo-OwnerCommented:
Leave that for now - keep going and if ASP is the problem, we can address that later.  I have seen some that work happily with ASP.NET 2, but a lot that don't !
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
H2OmikeIT ManagerAuthor Commented:
Arrgg!  I changed it on the default website folder and applied it to all the child nodes and now OWA is fubar.. it gives me a listing of all the mailboxes in text mode..  uh ohh.. any idea how to get this fixed?

mail.domainname.com - /exchange/

--------------------------------------------------------------------------------

[To Parent Directory]  4/7/2010 10:24 AM        
<dir> Alerts  4/7/2010 10:24 AM        
<dir> billb  4/7/2010 10:24 AM        
<dir> BKahn  4/7/2010 10:24 AM        
<dir> bobh  4/7/2010 10:24 AM        
0
 
H2OmikeIT ManagerAuthor Commented:
I did this on the default website, and also changed it to the 1.1 version, I've now changed it back to it's original settings in both places but it's still giving me the directory listing as described above.  When I try to go into my mailbox I have to authenticate again and then it lists everything in text.

To view the script map for an ASP.NET application
1.
 Open IIS Manager, expand the local computer by clicking the plus sign, and navigate to the folder that contains the ASP.NET application.
 
2.
 Right-click the folder and click Properties. The application's Properties dialog box appears.
 
3.
 On the Directory tab, click the Configuration button. The Application Configuration dialog box appears.
 
4.
 On the Mappings tab, select an ASP.NET application extension, such as .asmx or .aspx.
 

The Executable Path column of the dialog box will list the path to the ASP.NET ISAPI version used by the application. By default, the ASP.NET ISAPI is installed in the following location:

systemroot\Microsoft.NET\Framework\versionNumber

The version number shown in the path indicates the version number of the ASP.NET ISAPI used by the application. The ASP.NET ISAPI version determines which version of the runtime is used by the application.

Results:

mail.domainname.com - /exchange/mymailbox/

--------------------------------------------------------------------------------

[To Parent Directory] 8/17/2008  7:28 PM        
<dir> Calendar 1/22/2009 10:26 AM        
<dir> Contacts 1/11/2007 11:19 AM      
<dir> Deleted Items 3/15/2007  6:41 PM        
<dir> Drafts  4/1/2010  7:59 AM        
<dir> Inbox  5/2/2008 10:39 PM        
<dir> Journal 1/11/2007 11:19 AM        
<dir> Junk E-mail 1/11/2007 11:19 AM        
<dir> Newsletter 1/11/2007 11:19 AM        
<dir> Notes  2/4/2010  9:18 AM        
<dir> Outbox 1/11/2007 11:22 AM        
<dir> RSS Feeds11/16/2009  8:45 AM        
<dir> Sent Items 6/17/2009  3:11 PM        
<dir> Spam  2/8/2008  9:51 AM        
<dir> Sync Issues 1/11/2007 11:19 AM        
<dir> Tasks 10/7/2009  7:12 PM        
<dir> ZoneAlarm Challenged Mail 10/7/2009  7:12 PM        
<dir> ZoneAlarm Junk Mail

0
 
Alan HardistyCo-OwnerCommented:
Have a read of the following and see if you can restore the IIS Metabase from a previous backup:
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/d40b56ee-90d4-45e1-9b82-4aaea90eb02e.mspx?mfr=true 
0
 
H2OmikeIT ManagerAuthor Commented:
I restored to the original version since it looked like the automatic backups all happened after the changes.  That wiped out all of the directories.. so I restored the backup that I took right before that restore and now I'm back to where I was.
0
 
H2OmikeIT ManagerAuthor Commented:
Time for a $259 support call to Microsoft I think...
0
 
Alan HardistyCo-OwnerCommented:
Can you restore from tape / overnight backup?
0
 
H2OmikeIT ManagerAuthor Commented:
I have a backup, but I'm not sure how to restore just the iis metabase.. it backed up the system state, information store etc..  veritas backup exec 9.  (I know old version).  Everything seems to be working with Exchange, just OWA is screwed up.  
0
 
Alan HardistyCo-OwnerCommented:
You need to restore the MetaBase.xml file in %Systemroot%\System32\inetsrv only
Stop IIS Admin:
net stop iisadmin /y
Rename MetaBase.xml to Metabase.old
Restore MetaBase.xml from tape to the %Systemroot%\System32\inetsrv folder and restart IIS Admin service.
0
 
H2OmikeIT ManagerAuthor Commented:
whew.. OK, all is well now.  I did call Microsoft support and (to make a long story short) we fixed the OWA problem by deleting and recreating the virtual directories.  Then we looked at the Iphone sync problem and they sent me a hotfix for activesync.. now everything is working great!  I had patched the server up to current with Microsoft update and that hotfix was not included, so I'm not sure if you have to call them for it or not.  It had to do with this file:

File name      File version      File size      Date      Time
Massync.dll      6.5.7655.0      756,736      29-Jan-2009      18:59

I was on version 6.5.7638.1.  The hotfix updated it to 7655 and now all is working well although I had to turn off SSL for this account on the Iphone to actually get it to sync.  I'll include the hotfix for anyone looking for it.  

thanks for your help!
372368-intl-i386-zip.exe
0
 
Alan HardistyCo-OwnerCommented:
I've never had to update massync.dll (yet) to get Activesync to work, but there are other EE Expert's who offer that as a solution.  Not knocking it - but either way, you are fixed and glad all is well.  Sorry you had to call MS and pay.
Alan
0
 
Steve AndersonCommented:
H2OMike thanks for the update I've been looking everywhere for this, the MS website is no longer. cheers
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now