• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1764
  • Last Modified:

VBScript: Remote Desktop Disconnected. An Internal Error Has Occured

I have several laptops at my organization that will not connect to our terminal services server. They make it through the first phase of authentication (RSA token) without a problem. They then proceed to click the Remote Desktop Icon and the authentication box pops up, they enter their credentials and press connect and they get:

VBScript: Remote Desktop Disconnected. An Internal Error has occured.

Things I'm pretty sure of:
1. The server is not the problem other clients/laptops can connect without any problems.
2. It is not the users account. I can connect said users from other working laptops.
3. I'm fairly sure it is a setting within the laptops themselves. Pop-up blocker is turned off, all necessary activex controls are installed, the settings for IE8 are all the same.
4. Could it be a windows service? If so, which one?
5. I notice on the laptops that it does work on, there is a pop-up after they do phase two of authentication and hit the connect button warning about a certificate error, this is where it fails on the non-working laptops, right before this pop-up.

I have google'd the problem for three days, and can only find information on changing server settings, which I am pretty confident is not my problem.

0
andeporter
Asked:
andeporter
  • 3
  • 3
3 Solutions
 
andeporterAuthor Commented:
Hello Sector5, thank you for the response.
Unfortunately, I have seen all those threads...and they all indicate issues with the server. Since the server works fine for 90% of the clients I really feel like the problem is a setting on the laptops. I am leaning towards a recent windows updates as they just stopped working properly about a month ago.
0
 
knightrdCommented:
It may not be the user's account, it might be something in the registry or cached account itself. As a test I would choose a machine/user experiencing the problem (preferably one that doesn't use EFS) and back up the user's profile. Then I would reboot and login under an admin account to delete their profile. Then have them log back into the computer to create a fresh profile and allow the account to be cached. Ask them to re-test it and see how it works out.

If that fails, I'll make a suggestion based on what I would do in this situation. When I run into problems that lead to nothing but dead ends, I use the Microsoft Sysinternals tools to analyze everything at a much deeper level. In situations where the standard troubleshooting doesn't cut it and you really want to understand why something is failing, that is the best option. If you aren't familiar with the Sysinternals tools, they are a free download from Microsoft: http://technet.microsoft.com/en-us/sysinternals/bb842062.aspx

It would take a book to fully describe all the things you can do with Sysinternals, but I would take a look at the following programs: autoruns, procexp, & procmon. With procexp I've been able to identify Microsoft problems with Microsoft patches in some pretty weird situations where I couldn't track down what was launching a generic process shell.

However, procman is the most useful in general. It generates an unbelievable amount of information. Your first order of business is to explore the filters. I usually filter by specific programs, but you can filter by event classes and other criteria. Depending on what the problem is you may not know what to filter. I generally try to have as few things running as possible and reproduce the problem. I look for patterns in the data or clues about what to look for next.

Here's an example. When I was working for an oil company we started getting a lot of Circle of Wait issues in Powerpoint. Since it was effecting some people pretty high up, there was a lot of pressure to find an answer. None of the standard troubleshooting worked. So I made use of Sysinternals. In cases like these you are searching for a real needle in the haystack so to speak and you never know what you are going to find. So I started filtering all of the PowerPoint events so I could get a clue about what was going on. What I discovered was that the corporate antivirus software was causing the issue. A faulty definition update was the root cause. It just so happened that an even newer definition update was available, so I did an update and the problem was resolved. My point is that if you go the route I'm suggesting, you have a pretty good chance of figuring out the cause OR at least getting another idea for what you can try.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
andeporterAuthor Commented:
Knightrd. I truly appreciate your advise and comments. I'm going to tackle this problem again on Monday, and use some of your suggestions to see if I can pan out a solution. Thanks, and standby.
0
 
knightrdCommented:
That sounds good. One thing I forgot to mention about troubleshooting with those tools is that you can compare a computer that doesn't work to a computer that does work. There are different methods that work in different situations. Please just keep in mind that you MAY need to do a comparison if you can't find a clue or pattern in the data.

I also meant to mention something about autoruns. If you think it could be related to something that is running automatically, but aren't quite sure where it is coming from, autoruns breaks all the programs and files that run automatically into different tabs. It's like msconfig on steroids. You might also find an answer there.
0
 
knightrdCommented:
Didn't mean to say "breaks". Meant to say "lists"
0
 
andeporterAuthor Commented:
None of the provided solutions resolved the issue. I'm unsure how to award the points.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now