Mail enabling Sharepoint 2007 documents store using seprate Exchange 2007 server

I have a problem mail enabling a Sharepoint 2007 documents library to allow external users to email documents directly to the store, the setup is detailed below:

Setup: There is 1x Exchange 2007 box , 1x SharePoint 2007 box and 1x AD server

Also be aware of the following points:

1. I have the IIS SMTP server service enabled on Sharepoint server, with anonymous access enabled (as per MS guide)
2. I have configured this to only allow the exchange server (EXCHANGE01) to accept relay.
3. I have created send/ receive connectors in exchange and specified the SharePoint server IP, in both of the remote domain sections.  
4. I am using  SharePoint Directory Management Service  to create a mail enabled contact in AD, this creates fine and I then assign a SMTP address to the contact in the exchange management console.
5. The exchange 2007 server can send and receive internet mail fine, MX records are working for the domain.
When I  attempt to send an email though exchange to the contact address that has been created though SharePoint it returns the following error:

#554 5.4.6 Hop count exceeded - possible mail loop ##

Is there a way to fix this so the exchange server handles the incoming mail then relay's specific mail to the SharePoint server based on the contact address created by SharePoint document library, hence enabling the document store mail functionality?
steffik1354Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

itgrooveCommented:
That's how the directory management service is supposed to work (create the necessary contacts) but i find that it is sloppy, less control (more risk), etc.  Instead, I manage my manually.
1. Email enable your document library and give it an email address (such as doclibrary1@servername.company.com
2. Make sure servername.company.com is a valid A record in DNS (you can ping it validly by name)
3. Create a contact in Exchange whose email address is doclibrary1@servername.company.com (so it knows where to forward). Set whatever friendly lname you want for this library such as doclibrary1@company.com (notice the servername part is gone)
4. Finally, I run into this often, make sure you have set your SMTP aliasing right on the SharePoint Server in SMTP/IIS.
  1. Go into IIS/SMTP.
  2. Open up 'Domains'.
  3. Right click and choose New -> Domain...
  4. Add an 'alias' for the domain (company.com) as it is expecting only to see emails for servername.company.com
  5. Choose Finish
Hope that helps.
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
steffik1354Author Commented:
Excellent, thanks.. seems to be working now based on the steps above, I can now email documents to the library using documents@domain.com - rather then documents@server.domain.com.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.