Windows 7 cannot access network share on windows 2000

Alright so i know we have an very old server, but it still does the job. Basically we have windows server 2000 setup and on that machines we primarily use it to share files so recently one of my employees got a windows 7 machine running Windows 7 Home Premium 64-bit.

On our XP machines we would simply go to: \\Server-Name and then type in a user name and password. It continues to work fine on windows xp machines.

Instead on Windows 7, after we open run then type in \\Server-Name it prompts us for the password like it should but it keeps saying "Login failure: unknown user name or bad password"

I also tried it on my own laptop which runs Windows 7 Professional 32-bit and it wouldn't work either.

Any ideas? Do we need to upgrade the server to a newer OS?
checkmofoshodunoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brad HoweDevOps ManagerCommented:
Hi,

Windows7 uses NTLM 2 by default where as Windows 2000 use the previous version NTLM.

Take a look at this article for the correction.
http://www.tannerwilliamson.com/2009/09/windows-7-seven-network-file-sharing-fix-samba-smb/

Cheers,
Hades666
0
supportsCommented:
have u tried
domainname\username
password
0
checkmofoshodunoAuthor Commented:
http://windows7forums.com/windows-7-networking/23262-can-not-connect-server-running-windows-2000-server.html

First:


On the 2000 machine, go to Administrative tools / Local Security Policy / Local Policies / Security Options / LAN Manager Authentication Level then select 'Send LM & NTLM - use NTLMv2 session security if negotiated'.

(***I don't believe this first step is nessecary, it actually started working when i did the second step)



Second:


http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/02476acb-aa5f-4fcf-8079-4a697a065610

On the windows 7 machines set the following Registry key “HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel” to “1”.

If it doesn't exist create it as a DWord and set the value to 1 with the hexidecimal option selected.

Also, i got the option for a 32-bit or 64-bit. I guessed and went with 32-bit and it worked.

Hope this helps others who get stuck like i did.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rene_CaronCommented:
Wow ...checkmofoshoduno...you saved me...thanks for that fix...been looking to fix this for days :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.