Strange Connectivity Problem with 3COM 16 port Switch

Hi,

I'm new to Experts-Exchange and this is my first (though probably not last) question!  I'm really hoping that someone can help me out.

First off a little background - I'm a scuba diving instructor working in Bali and also happen to be the local computer "expert" (not so much from my expertise but since I have a degree in Computer Science that puts me light-years ahead of anyone else around here).

I've setup the office network here to be a little bit more efficient and secure than what it was when I arrived.  To briefly describe the setup I have:

•      Linksys Wireless-G ADSL Home Gateway (WAG200G) that acts as the office internet connection.
•      To this I have a server connected running Windows Server 2008 with DNS, DHCP, Active Directory installed and running.
•      Also to the router I have a switch connected (3COM Office Connect Fast Ethernet Switch 16 (3C16792C)).
•      To the switch I have all the office computers connected (6 in total).  I also have another switch connected to it (in another building) which has our CCTV recorder connected and then yet another switch which serves two additional computers in a classroom.  Both of those switches are 3COM 8 ports (3CFSU08).

Now to the problem:

I tidied up the cables behind the 16 port switch today (it was a horrific mess of cables) and in the process disconnected the cables, sorted them out then reconnected them (admittedly, not in the same sockets they were originally in).  Once everything was reconnected I quickly checked all of the machines to see if the network connectivity was working and it was on all expect two.

These two machines are in the main office so connected directly to the 16port switch.  The issue they are having is the "Limited or No Connectivity" due to an IP address not being assigned.  Attempting to repair (or ipconfig /release and then /renew) ends up with Windows telling me that the DHCP server cannot be reached.  Every other machine on the network is getting IP addresses fine and is working normally.

Now the strange thing is that if I plug those two machines directly into the Linksys router, then connectivity is restored.  It's only if they're plugged into the 16 port switch that they lose it.  I've tried everything I can think of including: rebooting the switch, changing ports on the switch, trying other computers on the ports of those machines, trying new cables, reinstalling network card drivers, running network card diagnostics, rebooting the server etc and nothing helps.

So I'm wondering if anyone has any ideas why the network works fine if I plug the computers directly into the router and not if I use the switch (keeping in mind that there are 4 other machines directly connected to the same switch which work, the CCTV works as do the two machines off in the classroom)?

I'll be happy to provide any additional information if you need it.

Thanks!
Alex.
AlexBSBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnnOminousCommented:
I was going to suggest that you might have cross over cables that the Linksys router can automagically switch around, but the 3COM switch is supposed to have auto MDI-MDIX on every port.

Have you tried swapping the problem cables for other ones? If that works, then one solution is to buy a couple of new cables. If it doesn't work, then the problem may lie in the computer NIC/connector.
0
AnnOminousCommented:
To clarify:

1) Try a new cable and a different port (both together) with a computer that's failing.
2) Try a working computer on a port and with a cable that fails.

According to your analysis, the first should fail, and the second should work. If so, then the problem lies with the NIC/3com. It can be neither a switch issue (e.g. vlan tagging) or a cable issue (since it works for 2).


0
AlexBSBAuthor Commented:
Thanks for the suggestions, I'll try this out tomorrow morning when no one is in the office and let you know the results!
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

AlexBSBAuthor Commented:
Ok I couldn't wait so I kicked a couple of people off their machines for 10 minutes while I tested and here's what I got:

Working Cable, Working Port, Computer that failed = Fail
Non Working Cable, Non Working Port, Working Computer = Pass

So it looks like it's a NIC issue somewhere.

However like I mentioned previously, if I plug the problematic NIC straight into the router then it works fine.  So what would make a NIC work fine when connecting to a Router but not work when connecting to a Switch?

I think I might just buy a cheap PCI NIC and try to see if that works.
0
pixr99Commented:
A couple more things you might want to check: In the failing computer's network card settings, check to make sure that someone hasn't "hard set" either the speed or duplex settings.  Way back when, a lot of switches had trouble negotiating speed and duplex so people used to manually configure this.  Some people haven't "unlearned" this yet :-)

Then check the switch for the same nonsense.

You may see a link light on both the computer and the switch and still be unable to pass traffic if this is the problem.
0
AnnOminousCommented:
Assuming that the original configuration worked and that it was plugged into the same switch, there must be two ports that work. So that implies the ports are configurable.

The 3C16792C ports do not appear to be configurable, so the issue that pixr99 describes should not apply in this case. But it also contradicts what we see to date.

Q: Do the lights on the switch when connected to a failing computer differ from the lights when connected to a working computer?

If the lights differ, then we can focus on configuration.
If the lights are the same, then we likely have a hardware issue.

Q: Are the failing and working computers connected to the same electrical circuit? If the site wiring has a faulty ground, or is on a separate circuit, the network cabling may be acting as a common ground. You might want to plug in a failing computer to a working computer power outlet and retry.

Finally, make sure that you either reboot or ipconfig /renew in order to test each connection. Otherwise, you might miss the good one(s).

My guess is that there is an electrical or hardware incompatibility (it happens) that the Linksys is more tolerant of, and the 3com switch is less tolerant of. If you are borderline, some ports may work, and some not, some of the time, depending on the weather.
0
AnnOminousCommented:
Finally, is it possible that the working computers have hard coded IP addresses? And that DHCP is enabled on the router? And that no MAC or other restrictions apply? Working on the Linksys appears to preclude this, but I need to ask since some information appears to conflict with what we see.
0
AlexBSBAuthor Commented:
Thanks for all the suggestions, I've run them through and maybe we can start narrowing this down.

First off - the electrical system.  That immediately sparked my interest since I'm in Bali in Indonesia and the power grid here is anything but stable.  Constant power outages, nothing is grounded, need a UPS for every machine and the generator not being powerful enough to run all the PCs and AirCon at the same time are daily norms here.  Unfortunately swapping around power connectors from working and failed PCs seems to not have made any difference at all.

Now to the switch lights:
- On the working computer the light generally stays on constantly and flickers whenever there is network traffic (e.g. I open up a web browser).  On the failing computer the light is constantly flickering very fast non-stop.

Also another thing I noticed is that if I power down a working computer and then power it back up, as soon as windows starts up and I can go to Start -> Control Panel -> Network Connections and the network connection screen appears immediately.  On the failing computer trying the same it takes approx. 1 minute for the network connection screen to appear (regardless of whether the computer is plugged into the switch/router or even if the cable is simply unplugged).  When plugged into the router the internet connection works before then (e.g. Skype will connect and browsers work) but it takes about a minute to be able to access that connection through control panel.

Most of the time I can tell if the failing computer is going to work or not by just looking at the network connection icon.  If it's plugged in the router then it finds the DHCP address almost instantly and doing a repair on the connection works in a few seconds.  When it's plugged into the router I get the "acquiring network address" icon for a good minute and doing a repair simply hangs at "Renewing IP address" for a minute or so before I get an error message.  I've been doing this every time I change something on all the computers just to be sure.

All the computers have DHCP enabled and no hard coded addresses.  The router is set as a DHCP Relay with the server.  The server is using the MAC Filter Callout dll (http://www.petri.co.il/filter-mac-address-windows-server-2008-dhcp-server-callout-dll.htm) which seems to be working fine.  Just to make sure I disabled it and checked connections but still having the same problem.  Finally the DHCP server has IP reservations enabled based on MAC address but that's also working fine.
0
AnnOminousCommented:
Q: Is there a color difference on the lights? This might happen if the speed changes.

I've seen fast blinking when there was a loopback on the router (i.e. plugged into itself), but that does not seem to be the case here.

Can you confirm that it worked originally? And that it was plugged into the 3com switch? If so, you should be able to cycle through all the ports until you find the one it was connected to originally.

Q: Is the hardware on all the failing computers identical?
Q: If not, are the NICs identical?
Q: Is the identical hardware/NIC on any of the working computers?

That is, is it only one type of hardware that is failing?

I would also try running WireShark on the server (or a workstation if required) in order to capture the DHCP commands sent from the workstations as they are connected to the network. I would be interested to know if the DHCP Discover broadcast occurs when you plug in the problem computer (or anything at all). If so, it would suggest that the issue is on the DHCP server end, but why would it then work form the router...

If I had this problem, I would start swapping parts between working and non-working systems. We've eliminated the cabling and physical ports as the issue. It's down to the computer itself or an incompatibility between the switch and NIC on the computer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlexBSBAuthor Commented:
I did what you suggested and tried every port on the switch with the problematic computers.  I was able to find one port which works for each of them so they're all connected onto the switch once again.  Not too sure why they decide to work on that port and not on others but honestly I'm more glad that they're just working now.

Hardware is different for every machine - different motherboards and NIC cards (generally all Gigabyte motherboards with integrated Ethernet adapters though).

I'll give WireShark a go when the office isn't so busy and let you know the results.

Thanks again!
0
AlexBSBAuthor Commented:
Ok I found it.... and you're not going to believe how stupid it is.

When I tried every port I also decided to write down which computer is connected to what port on the switch.  Doing that I discovered that two of the cables didn't seem to go anywhere.  The switch lights are blinking but there simply cannot be another computer or device connected to them since I've checked them all.

So then I realized that it was probably the same cable just looping back somewhere and coming out another side of the wall... which it is.  Unplugging this cable fixes everything.  The failing computers work fine on any port now...

So in short, all this was caused by a single cable being plugged at both ends into the same switch (port 8 and 9 though don't think that matters)!  In my defense, the two ends of the cable come from opposite directions in the wall so there's no easy way to tell that it's the same one.  It must have been placed before I arrived going in one direction (and passed through the cable cover thing in the wall) and then someone later moved it to plug into another computer somewhere else (rerouting it through the cable cover on the wall).  End result is that one end disappears in one direction and the other end in the opposite direction!

Still wouldn't have arrived at this if you hadn't suggested just trying every port so thanks a lot for your help!
0
AlexBSBAuthor Commented:
Solutions offered led me to find the real solution (which was basically me being stupid).
0
AnnOminousCommented:
"I've seen fast blinking when there was a loopback on the router (i.e. plugged into itself)"

Glad to get it solved. I was about to through up my hands... ;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.