• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 597
  • Last Modified:

How do i solve this error found in Apache Error log

[warn] (OS 10038)An operation was attempted on something that is not a socket.  : getsockname failed.
This error is showing in the Apache Error log.
I need a definition of this error, and what can I do to stop it.
This error is showing in the software am using as "Can not connect to localhost as root MySQL Error: Can't connect to MySQL server on 'localhost' (10038)" Though the software is running normally
0
jmhabis2
Asked:
jmhabis2
  • 3
  • 3
1 Solution
 
KalpanCommented:
mysql server might not be running...

try doing

/etc/init.d/mysqld restart or try to find the mysqld with particular mysql installation directory and restart that

Thanks

Kalpan
0
 
jmhabis2Author Commented:
We are running on windows machine.
0
 
KalpanCommented:
try to restart  the mysql server by going into the control panel > Services > mysql instance...


and click on restart or start
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
jmhabis2Author Commented:
we did that so many times... same error is happening randomly
0
 
jmhabis2Author Commented:
The Back-End:
Windows Server 2003 (x64 Edition).
My SQL Version: 5.0.19
Apache Version: 2.2.4
The Total Number of Users is: 97
0
 
KalpanCommented:
I had the same problem. and this is how I resolved it. remove mysql from your computer.
MySQL reads it's configuration directives from a text file called my.ini. This file
should be placed in the main Windows folder which will be /WINNT on Windows NT/2000 and
/WINDOWS on Windows 98/XP/2003.Now let's see what should your my.ini file look like?
Create a new my.ini file in your Windows installation folder and copy/paste following
text in it.

[client]
port=3306

[mysqld]
port=3306
enable-named-pipe
socket=MySQL

skip-locking
set-variable      = max_connections=64
set-variable      = read_buffer_size=1M
set-variable      = key_buffer=8M
set-variable      = max_allowed_packet=1M
set-variable      = table_cache=64
set-variable      = sort_buffer=512K
set-variable      = net_buffer_length=8K
set-variable      = myisam_sort_buffer_size=4M
server-id      = 1

basedir = D:/mysql-4.0.14b-win-noinstall/
datadir = D:/mysql-4.0.14b-win-noinstall/data/

skip-bdb

innodb_data_file_path = ibdata1:10M:autoextend
set-variable = innodb_buffer_pool_size=32M
set-variable = innodb_additional_mem_pool_size=4M

set-variable = innodb_log_file_size=8M
set-variable = innodb_log_buffer_size=8M

innodb_flush_log_at_trx_commit=1

[mysqldump]
quick
set-variable      = max_allowed_packet=8M

[mysql]
no-auto-rehash

[isamchk]
set-variable      = key_buffer=10M
set-variable      = sort_buffer=10M
set-variable      = read_buffer=2M
set-variable      = write_buffer=2M

[myisamchk]
set-variable      = key_buffer=10M
set-variable      = sort_buffer=10M
set-variable      = read_buffer=2M
set-variable      = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

The my.ini file should at least contain the path to the MySQL installation and data files
folder. Since I am assuming you installed MySQL in D:\mysql-4.0.14b-win-noinstall folder,
this folder's path has been put in my.ini file.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now