UNC with domain name doesnt work

Hello,
one Windows XP PC cannot access UNC path containing domain name of desired server. UNC path with IP address of the same server is working. Ping to the server via domain name is also working. I have tried to restart lanmanserver and lanmanworkstation services on Widnows XP PC, I have checked there are no strange protocols enabled on network device and windows sharing is enabled. There is no firewall enabled.

Thanks for any hints in advance.
spika-sroAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

acl-puzzCommented:
here is small but nice explanation see if you are missing somthing

http://compnetworking.about.com/od/windowsnetworking/g/unc-name.htm
0
spika-sroAuthor Commented:
Thanks, but I didnt find anything usefull there.
When I try to open
\\winserver - error message appear - network path not available
\\192.168.1.1 - this works, I can see shared folders
Maybe this could be clue:
\\locahost - doesnt work
\\127.0.0.1 - this works
0
PorpathamCommented:
Hi,

Please type the Uncs here. I just want to check here.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

PorpathamCommented:
Hi,
U checked the Trust relationship and Packets(Like 2 way communication between 2 devices).
0
acl-puzzCommented:
can u access like this \\winserver\shared-file-name ?
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Sounds like you need to use the FQDN to get to the server.  

Please try to use \\server.domain.com\shareName to get to your destination.

Not sure how you have your network setup but it seems like just the NetBIOS name is not enough or you don't have WINS properly configured.
0
tonyperthCommented:
If local host does not work either then you are either not using your hosts file on your nic or your hosts file is missing the entry for local host, it may also have some weird entries for the server or domain name.  Find c:\windows\system32\drivers\etc\hosts file, open it in word and make sure that the only entry in it is:

127.0.0.1 localhost

everything else should be dealt with by the DNS and WINS servers.
0
B HCommented:
you should hard-enable netbios on that xp machine's network adapter:

control panel > network > right-click the interface, properties, tcpip, properties, advanced
on the WINS tab, put the dot by enable netbios, hit ok a few times
while you're over here, double check that the ONLY dns server this interface has, is your domain controller/dns server

since it can't even resolve localhost, you need to also check out this:
start > run:
notepad %systemroot%\system32\drivers\etc\hosts
in that file, make it say this
127.0.0.1  localhost
(and nothing else at all, save it)

after that, just to be sure, do this:
start > run > cmd
ipconfig /flushdns && ipconfig /registerdns
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
spika-sroAuthor Commented:
\\winserver\NETLOGON - doesnt work
\\winserver.mydomain.local\NETLOGON - doesnt work
\\192.168.1.1\NETLOGON - works
\\127.0.0.1 - works
\\localhost - doest work
ping winserver - works, I get the response from IP address 192.168.1.1
ping localhost - works, I get the response from IP address 127.0.0.1

In Advanced TCP/IP settings of network adapter the WINS tab look like this:
- no WINS server
- Enable LMHOST lookup - checked (dont know what this means)
- NETBIOS settings - Default (Use netbios settings from DHCP)
It looks like on other computers in network which have no problem at all.

How can I check the Trust relationship and Packets(Like 2 way communication between 2 devices)?
0
tonyperthCommented:
try typing
nslookup winserver

and see where you computer is looking for DNS names, as it sounds as though it is not looking in the right place.
0
SteveIT ManagerCommented:
Check the security and permission on the server and user account - have you tried other user accounts on the PC itself ?

If you can ping via IP and not by name, check DNS and the eventlog
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Please try this command:
           netsh int ip reset c:\resetlog.txt
0
ChiefITCommented:
In Advanced TCP/IP settings of network adapter the WINS tab look like this:
- no WINS server
- Enable LMHOST lookup - checked (dont know what this means)
- NETBIOS settings - Default (Use netbios settings from DHCP)
It looks like on other computers in network which have no problem at all.


Use Netbios over TCP/IP

If you have no wins server or a configured LMHOST file, your netbios will not go through the broadcast domain.

But, since the FQDN doesn't work, my guess is you are using IP version 6. This is a tunneling protocol that will block DNS and Netbios.

So, type IPconfig /all at the command prompt and please provide us with that information.

ALSO: make sure that "file and print sharing" is enabled for that computer as well as the browser service is started.
0
PorpathamCommented:
Hi,

Check send and receive packets. And you checked with some other PC's. And try to add it with DOmain Again.. Using "Network ID" option.
0
PorpathamCommented:
Hi,
Please check WINS is working or not? If WINS is not working, you may also facing this kind of problem.

Try to check with the help of this Link:
http://support.microsoft.com/kb/300986
0
PorpathamCommented:
Hi,

First add the Windows Xp Client again. then try again everything like.

Check Netbios
Check DNS
Check WINS

It will work fine.

Expecting reply.
0
johnb6767Commented:
Any chance Offline Files is enabled on this machine, and synching with this server?
0
PorpathamCommented:
Hi,
       Download SyncToy 2.1 from server and Use. Any way u have to resolve this issue. Then only we can sync with Server. Or else no use with Sync Toy.

And please add IP on host file. If u added it please cross check it.

If u can please run a combofix on it.
It may have some unwanted spyware in it.
Sometime that spywares may create some IP filters in it.
Please check and reply.
0
PorpathamCommented:
Hi,

          Sorry i missed to mention this information.SyncToy 2.1is a free microsoft Product.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.