• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 955
  • Last Modified:

uddi HTTP 403 Forbidden

Hi,

I created a service (web services) using uddi services from Windows Server 2003.
The only way to access uddi services is using "https" and not "http" on the local machine, this is, using "https://computername/uddi/". However, when using code in Infopath 2007 and I use the option to "Add Web Reference" to the project, when I try to search for the web services and I write the address "https://computername/uddi/addwebreference", it gives me the following errors:

- "This website requires you to log in."
- "This error (HTTP 403 Forbidden) means that this program was able to connect to the website, but it does not have permission to view the webpage."

- "There was an error downloading 'https://stserver/uddi/addwebreference'.

The request failed with the error message:
--
<head><title>Document Moved</title></head>
<body><h1>Object Moved</h1>This document may be found <a HREF="https://stserver/uddi/addwebreference/">here</a></body>
--."


If I try to use only "http" it gives me an http 404 error, even when I try to browse.
I have tried to allow anonymous access in IIS for the uddi web site, but still does not work.
When I try to create a certificate in IIS for the uddi web site, the "Server Certificate" button is disabled.

Please can someone give me some advice on this.

Thank you.
0
moz-tech
Asked:
moz-tech
1 Solution
 
sureshmartinCommented:
Create a test jsp file under the application and try hitting the file using the same url.

Thanks
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now