Failed to generate a user instance of SQL Server 2008

i try both strong-typed dataset and sqldatasource to get connection from sql server 2008 but it gave me error like :

Failed to generate a user instance of SQL Server. Only an integrated connection can generate a user instance. The connection will be closed.

while using conventional connection like describing connstring :

private static string connstring = "Data Source=123\\SQLEXPRESS;Initial Catalog=productdb;User Id=xx;Password=xxx;";

it worked
untitled55.bmp
LVL 1
doramail05Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Christopher GordonSenior Developer AnalystCommented:
Is this a new instance of SQL Server?  Based on the error message, the box may not have been configured to accept SQL authentication.  For some reason this is the default for SQL Server instance install.
0
Christopher GordonSenior Developer AnalystCommented:
if that ends up being your issue here is a link that might be helpful:
http://kbase.gfi.com/showarticle.asp?id=KBID002804
0
doramail05Author Commented:
ok. i followed the article and try to configure, but found that they are default settings. no changes being made, and the issue hanging still
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Christopher GordonSenior Developer AnalystCommented:
OK, just to make sure I understand, it was not configured for Mixed Mode?  So, you made the configuration change, restarted the SQL server service, and you're still getting the same error?  

If you check the properties, is it still Windows Authentication only mode?
0
doramail05Author Commented:
it is mixed mode while login into sql server from management studio by default, that i didnt change it.

0
doramail05Author Commented:
got it already.

fixed with sql server express 2008 sp1.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Christopher GordonSenior Developer AnalystCommented:
great!  sorry wasn't able to help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.