Mount samba share (CentOS)

Hi,


I have two (CentOS 5.4) Servers, I have managed to setup samba on first server and is working fine as I have tested from windows machine (windows machine can access the share \\linux1)

Now on the 2nd Centos Machine, I'm trying to mount it, but it just doesn't work. I tried the following commands:

mount -t cifs //linuxserver1/backups -o username=XXXXXX,password=****** /backups
mount -t cifs //192.168.0.11/backups -o username=XXXXXX,password=****** /backups
mount -t cifs linuxserver1:/backups -o username=XXXXXX,password=****** /backups
mount -t cifs linuxserver1:/backups /backups

I get the following error message:
mount: wrong fs type, bad option, bad superblock on //192.168.0.11/backups/,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

When I check the dmesg I see the following logs
#dmesg | tail
 CIFS VFS: cifs_mount failed w/return code = -22
 CIFS VFS: cifs_mount failed w/return code = -22
 CIFS VFS: cifs_mount failed w/return code = -22
 CIFS VFS: cifs_mount failed w/return code = -22


Any help/advice will be must appreciated

Thanks











GuildOfDruidsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ry_berkCommented:
Try re-installing nfs-common

Also check these files and this walkthrough:

http://fconfig.wordpress.com/2006/08/17/setting-up-a-fedora-nfs-server/
0
ry_berkCommented:
These files:

/etc/exports
/etc/hosts.allow
/etc/hosts.deny
/etc/sysconfig/nfs


Sorry
0
medveddCommented:
Stupid question - do you have samba-client installed on 2nd machine?

yum list | grep samba-client
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tty2Commented:
mount.cifs -h

Usage:  mount.cifs <remotetarget> <dir> -o <options>
Options:
      user=<arg>
      pass=<arg>
      dom=<arg>

mount.cifs //linuxserver1/backups /backups -o user=XXXXXX,pass=******
0
GuildOfDruidsAuthor Commented:
Yes it was a stupid question for you but not for me :P Thanks alot for your help.




0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.