• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 457
  • Last Modified:

Cannot find the object 'sp_positivepay', because it does not exist or you do not have permission.

For Microsoft Dynamics GP on SQL 2005, I am conducting a test upgrade from GP 9.0 to 10.0.

Anyway, for this test upgrade, I followed the Microsoft KB article procedures on moving data from one server to another.  So, I ran the grant.sql script against all GP company databases per those procedures.  But, when I try to run the script against the DYNAMICS database, I get the following error message in SQL 2005 Management Studio:

Msg 15151, Level 16, State 1, Line 1
Cannot find the object 'sp_positivepay', because it does not exist or you do not have permission.

I cannot delete this stored procedure, in order to get rid of this error, as SQL does not show it as “being there”.  Now, it is in the sysobjects table of the DYNAMICS database.  But, how can I get rid of it so that I can run grant.sql?
1 Solution
apitechAuthor Commented:
Disregard....this is resolved.

Even though grant.sql was calling the stored procedure “sp_positivepay”, the name of it is actually “coastuser.sp_positivepay”.  In other words, it was going by a different namem even from what it was called in the sysobjects table!

Once I deleted that stored procedure, grant.sql ran just fine and within a millisecond at that!

The client said that it was OK to delete it, since it references an outdated positive pay procedure that they programmed in 2002.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now