• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 471
  • Last Modified:

Username's aren't authenticated to domain controller while using VPN

We have had a couple of users lately who use VPN often from their home.  Once connected to the VPN successfully (they can ping the server, get a virtual IP address from our network), they run a simple login script that maps a few network drives from the server.  The problem is, the batch file errors out when they try to run it...sometimes.  When it errors out, it complains of an invalid username.  When they simply try to manually connect to a shared resource on the server, by typing \\servername\share in the run command, it prompts them for a username and password.  They type in their username and password, and it gives them the following error:

"The username you typed is the same as the username you loged in with. That username has already been tried, the domain controller cannot be found to verify that username."

Yet, if they use the Administrator account, it then maps just fine.  Any idea what the problem is here?  Many times it works perfectly fine, but other times, they get this error (and this is really only happening to two users...the rest all work fine all the time).

We have a Sonicwall 2040 firewall and run a single Windows 2003 domain controller server.

Thanks.
0
jbobst
Asked:
jbobst
4 Solutions
 
thabashCommented:
Check if ur firewall allowing ur vpn to see ur internal network and servers espicially the dc
0
 
matiaslCommented:
0
 
SteveIT ManagerCommented:
Check your DNS and permissions
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
Cas KristCommented:
Run ipconfig on a PC with troubles when VPN is connected. Especially take a look at the DNS-servers and WINS-servers. You could try enabling the IP Helper in the Sonicwall, also enable Netbios in the IP Helper.
When the DNS-server is OK, try running NSLOOKUP (make sure the DNS-server is your domain controller) and type the name of the domain and domain controller.
0
 
thabashCommented:
Can u ping the both side
0
 
jbobstAuthor Commented:
"thabash:Check if ur firewall allowing ur vpn to see ur internal network and servers espicially the dc"
"thabash: Can u ping the both side"

Our VPN and firewall have been working fine now for years, with no change to the configuration.  It's just two users who have had this problem lately.  The first one who had this problem, seemed to be fixed after I re-installed a fresh copy of Windows.  The second user just started complaining about this last week.  He can ping the servers just fine while connected, it's just when he tries to map the network drives that it doesn't like his username for some reason...yet if he uses a different user account, it works just fine.

"sgsm81:Check your DNS and permissions"
What should I specifically check with DNS and permissions?  This user has worked fine with the VPN for years now, and all of a sudden, he alone is having this authentication problem.

caskris and matiasl:  I'll try those things this week and get back to everyone soon.
0
 
jbobstAuthor Commented:
Everyone was helpful, it's just that our Sonicwall VPN has been always problematic, and this issue is just too random to fix it seems.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now