Can't ping anything through Cisco ASA 5505 IPSec VPN Connection

We are trying to setup a VPN connection with little success.  We are able to connect to the network using Cisco's VPN Client.  However it doesn't see anything else through the VPN connection.  We aren't even able to ping the gateway.  As a matter of fact the gateway that gets assigned to you is also the IP that is assigned to you.  I don't know if that is how its supposed to be because I am no Cisco guru.  So to sum things up, we are able to connect to the VPN, we just are able to see any of the devices on that network once we are connected.  Below is the running config.
: Saved
:
ASA Version 7.2(3) 
!
hostname ciscoasa
domain-name default.domain.invalid
enable password encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group ppoe-hda
 ip address x.x.x.x 255.255.255.255 pppoe 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd  encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0 
access-list inside_access_in extended permit ip any any 
access-list outside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool HDA 192.168.1.200-192.168.1.252 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group hdainc.com request dialout pppoe
vpdn group hdainc.com localname ghgggvjggj@sbcglobal.net
vpdn group hdainc.com ppp authentication pap
vpdn group ppoe-hda request dialout pppoe
vpdn group ppoe-hda localname hujhovfgvg@sbcglobal.net
vpdn group ppoe-hda ppp authentication pap
vpdn username jhgjhkjh@sbcglobal.net password ********* store-local
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.99 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
group-policy hdaremote internal
group-policy hdaremote attributes
 vpn-tunnel-protocol IPSec 
username marc password  encrypted privilege 0
username marc attributes
 vpn-group-policy hdaremote
tunnel-group hdaremote type ipsec-ra
tunnel-group hdaremote general-attributes
 address-pool HDA
 default-group-policy hdaremote
tunnel-group hdaremote ipsec-attributes
 pre-shared-key *
prompt hostname context 

: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

hdaincAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gavvingCommented:
You don't have Nat Traversal enabled, so if you are testing this from behind another firewall that's NATing your traffic, it'll connect but won't pass any traffic.  

crypto isakmp nat-traversal 20

is the command to enable that feature.

Also it is rather normal to get the same IP number as your default gateway that you're assigned when you connect to the VPN.  This is normal.  Another possible problem you can run into with using the 192.168.1.x network as your primary VPN destination, as that's also the same IP subnet that's used by alot of other networks and firewalls.  If your sourcing your VPN test session from another network that's using 192.168.1.x network locally, It will connect but fail to pass traffic as all your traffic ends up going out the local network port and not thru the VPN tunnel.

And one last thing, you don't have Split Tunneling enabled.  This feature enables the remote VPN clients to access the Internet through their internet connection at the same time they're connected via the tunnel.  Refer to: http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080702999.shtml

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hdaincAuthor Commented:
Gavving,

Thanks a bunch.  I'll get this a try when I get back to work on monday.  It makes sense and thanks for the great explanations and suggestions.
0
hdaincAuthor Commented:
Great explanation and easy to understand.  Thanks!
0
bml104Commented:
crypto isakmp nat-traversal 20 is what i needed. It is odd that the VPN wizard did not enable this for me.
0
carrolc575Commented:
same as above
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.