Blackberry not connecting to outlook anywhere in exchange 2007

I have recently moved a client to Server/Exchange 2008/2007 and now blackberry and other mobile devices can not connect to exchange for mail.  I ran the microsoft exchange rpc/http connectivity analizer and came up with this error.

Testing Http Authentication Methods for URL https://remote.lislearchitecture.com/rpc/rpcproxy.dll 
  Http Authentication Test failed
   Additional Details
  A Web Exception occurred because an HTTP 404 - NotFound response was received from IIS7  
 
Any help would be much appreciated!
wjevans69Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wjevans69Author Commented:
Thank you, i'll have a look right now.
0
Hilal1924Commented:
Also This link will be really useful:

https://www.testexchangeconnectivity.com/

Best Of Luck

Hilal
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

ashishkpandeyCommented:
Please upgrade the exchange server to SP2 with all roll ups.
0
Hilal1924Commented:
@Ashishkpandey .. Where did that come from ?

Hilal
0
wjevans69Author Commented:
Thx hilal ...that's actually what I used to generate the error.
0
Hilal1924Commented:
Oh Cool :)

Hilal
0
wjevans69Author Commented:
it does appear that i'm running exchange 2007 with no service packs...so ashishkpandey suggestion is probably a good one.
0
hwdinfotechCommented:
Yep, you need Exchange 2007 sp2 installed.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wjevans69Author Commented:
Went through the SP1 and SP2 installs and still could not connect with the BB internet service. Was poking around in the server interal site and found a mention of this url. https://mydomain.com/remote. So I logged back into the BB internet service and pointed the server url to https://remote.mydomain.com/remote and it connected right away. Email account successfully added. It was the SP1 and SP2 updates that allowed for this to work so thank you very much for the help in this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.