Blackberry not connecting to outlook anywhere in exchange 2007

I have recently moved a client to Server/Exchange 2008/2007 and now blackberry and other mobile devices can not connect to exchange for mail.  I ran the microsoft exchange rpc/http connectivity analizer and came up with this error.

Testing Http Authentication Methods for URL https://remote.lislearchitecture.com/rpc/rpcproxy.dll 
  Http Authentication Test failed
   Additional Details
  A Web Exception occurred because an HTTP 404 - NotFound response was received from IIS7  
 
Any help would be much appreciated!
wjevans69Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
hwdinfotechConnect With a Mentor Commented:
Yep, you need Exchange 2007 sp2 installed.
0
 
wjevans69Author Commented:
Thank you, i'll have a look right now.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Hilal1924Commented:
Also This link will be really useful:

https://www.testexchangeconnectivity.com/

Best Of Luck

Hilal
0
 
ashishkpandeyCommented:
Please upgrade the exchange server to SP2 with all roll ups.
0
 
Hilal1924Commented:
@Ashishkpandey .. Where did that come from ?

Hilal
0
 
wjevans69Author Commented:
Thx hilal ...that's actually what I used to generate the error.
0
 
Hilal1924Commented:
Oh Cool :)

Hilal
0
 
wjevans69Author Commented:
it does appear that i'm running exchange 2007 with no service packs...so ashishkpandey suggestion is probably a good one.
0
 
wjevans69Author Commented:
Went through the SP1 and SP2 installs and still could not connect with the BB internet service. Was poking around in the server interal site and found a mention of this url. https://mydomain.com/remote. So I logged back into the BB internet service and pointed the server url to https://remote.mydomain.com/remote and it connected right away. Email account successfully added. It was the SP1 and SP2 updates that allowed for this to work so thank you very much for the help in this issue.
0
All Courses

From novice to tech pro — start learning today.