UNABLE TO REALY MAIL FROM COPIER

Hi,

I have an internal application which needs to send mail to external e-mail addresses. I've configured the application to use Exchange 2007 to send the mail as SMTP server. This Exchange server has HUB, Transport and CAS roles installed. However, as I have seen it is not doing so. But it is sending mail internally fine.
How can I configure Exchange 2007 so that it can send mail from the internal application and relays it externally?
Note: I am using application as a copier. And there are two copiers in the environment. Both are sending mails internally. But not route mail externally.
ProValAsked:
Who is Participating?
 
AkhaterConnect With a Mentor Commented:
0
 
ProValAuthor Commented:
what setting need to be done on copier for this.
Please suggest, right now which the help copier internal mails are working.
Is thier any additional setting required to do on copier also.
0
 
Mahmoud SabryCommented:
no you needn't any internal configuration on the coppier

but to allow relay to external domain, you must create new receive connector that support this

to create this connector follow these steps

This should explain why, in the above scenario, emails sent to internal users are received but not to external one, that is because Exchange is refusing to relay. To solve your problem and enable your application/web server to be able to send external emails, you should allow it (or its IP address) to relay emails through your Exchange server and here is how to do it in Microsoft Exchange 2007 and Microsoft Exchange 2010.

   1. Add another internal IP to your exchange server, say 1.1.1.1
   2. Create a new receive connector, configure it to listen only to the newly added IP address & accept SMTP connections only to the application\web server IP address. This can be done by GUI using Exchange Management Console or through Exchange Management Shell by running

      New-ReceiveConnector -Name AllowRelay -usage Custom -Bindings '1.1.1.1:25' -fqdn server.domain.com -RemoteIPRanges WebServerIpAddress -server MYEXCHANGESERVER -permissiongroups AnonymousUsers

   3. Now that the connector is created, you should allow relaying on that connector, this can only by achieved using Management Shell as shown below.

      Get-ReceiveConnector AllowRelay | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

   4. Finally configure your web server or Application to use the Exchange server's newly assigned IP 1.1.1.1 as SMTP server.

N.B.:Make sure to change the 1.1.1.1 by the additional IP you added to your Exchange server, WebServerIpAddress with the IP of your Webserver/application, MYEXCHANGESERVER by the name of your exchange 2007/2010 and server.domain.com by the FQDN of your exchange server.
0
 
Khurram Ullah KhanCommented:
You have to create a receive connector as the gentlemen mentioned above and check anonymous for receving emails, if you are still unable to send emails to outside then try to check "Externally secured" and then check if the emails are receiving or not.
0
 
AkhaterCommented:
@ProVal have you read my article ? basically msabry06 copy pasted it for you

what do you find difficult to do, my article should solve your problem
0
All Courses

From novice to tech pro — start learning today.