SQL Server 2008 app date time format is not like the one set on regional settings

Hi guys , I have been experiencing the following problem, Just got a new laptop with win 7 pro and installed MSSQL SERVER 2008 , I have set my laptop's Regional Settings to Greek , which means that the date format is DD/MM/YYYY.
When I connect to sql server via an ERP application the date format shown is MM/DD/YYYY.

I double checked my regional settings , the Locale settings is everything set to greek and the date formats are the expected ones , I even changed the default language for the sql server login to greek , but the problem remains. I have done this installation type 100 times on XP and never had such a problem.
Do you have any Ideas???? I am sure it is not the application because I have found another laptop running win 7 and the sqlserver 2008 and the same erp application with no problem , I checked all the settings on the other pc and are identical with mine.
I really can't figure this out.
Thanks
George
pamgeoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gothamiteCommented:
I am not sure what your ERP application is doing exactly but have you checked the language setting for the login that the application authenticates to SQL? This can affect how dates are interpreted by SQL.
0
pamgeoAuthor Commented:
if you mean the sql login I use the sa user and have tried using the language to english , british english , and greek. None of them worked
0
gothamiteCommented:
To eliminate the application as the cause of the issue, could you network the two computers together and then reconfigure the working ERP application to talk to the newly installed SQL Server?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pamgeoAuthor Commented:
when I actually did try to connect to the sql server from another pc every thing went fine, Changed the regional settings to English(US) rebooted , changed back the regional settings to greek an problem solved!!!

Thanks again
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.