Remote Desktop with RDP is working inside Home Network but not via Internet

Hi
Remote Desktop is working inside Home Network but not via Internet. IP provided by ISP seems to be fixed and port 3389 is open.
It's possible access html pages on data server, there is apache on data server.

"System diagram" with some additional information on enclosed file - any idea?

Tapio
ProblemWithRemoteDesktop.pdf
Tapio61Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

B HCommented:
what is the last digits of the ip you want to remote into?  i can't tell in your diagram... in what you call RR24, you need to allow tcp 3389 inbound to 10.0.0.x (whichever one you want remote desktop to go to)

also, on the target machine, you need to make sure it is accepting remote desktop inbound, either via windows firewall on that machine, or the checkmark that says 'allow people to connect here'

the html pages accessed on the server deal with port 80 and don't relate to this much
0
Rick_O_ShayCommented:
Did you test with the Ubuntu machine locally before trying it remotely?
0
acl-puzzCommented:
" IP provided by ISP seems to be fixed and port 3389 is open."


Linux Ubuntu which is mobile connection is connecting from internet right?

if this pc issue this command

telnet  x.x.x.142  3389    

does it shows an blinking cursor or if it is an ubuntu then install nmap on this mobile pc and do scan on x.x.x.142

does it shows port 3389 is open?

 
0
Redefining Cyber Security w/ AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Join our webinar on Sept. 21st to learn more about leveraging AI and machine learning to protect your business.

Tapio61Author Commented:
Dear all, thanks about your very fast reply :)

bryon44035v3
I want remote to IP 10.0.0.3, please see also enclosed attachment for settings of A-Link RR24.
Firewall of 10.0.0.3 is turned off.

Rick_O_Shay
I have test it and everything works locally (inside Home Network) but not behind A-Link RR24.

acl-puzz
telnet  xx.yy.zz.142  3389 shows following:
    Trying xx.yy.zz.142...
    Connected to xx.yy.zz.142.
    Escape character is '^]'.
    Connection closed by foreign host (this logout will happen after 30 seconds or something like that)
One additional question: I can see my login name on login screen (as "Tapio" in this case).
Is this login screen generated
- by 10.0.0.3 - then it means that there is some problem with access rights or
- is this login generated by Terminal Server Client software

Br.Tapio
PortForwarding.png
0
acl-puzzCommented:
try UDP mapping also...

on pc 10.0.0.3 keep open tcpipview http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

now try connection from mobile client do you see any connection initializing from  mobile client and in "state" any SYN  from this mobile client?

if it shows mobile client ip even for a moment that means mobile client at least once reached to 10.0.0.3 and port forwarding is happening properly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tapio61Author Commented:
acl-puzz
Thanks about your advice.
Tomorrow I have more time to continue with this and I will inform you.

Tapio
0
ThunderdCommented:
You need to open port 3389 at your firewall.
0
Tapio61Author Commented:
Hi

I did not find final problem but after fresh installing of WinXP everything is working okay.
Method from acl-puzz was most professional that's why I give all points to him.
Other answers were also good but as you can see from attachment, I have test these and they seems to be working.

Thanks to everybody about your support.

Tapio
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.