Why is my external HDD recognized on my netbook and not on my laptop?

Why is my external HDD recognized on my netbook and not on my laptop?

It happened today, after running ComboFix on my laptop (HP Compaq nx7300 Windows XP Pro SP3). There's a sound when I plug the external HDD in, and in the Window for Safely remove hardware, my external HDD is recognized. But it doesn't get displayed in My Computer menu, so there is no way to access it now. Properties (Safely remove hardware): "This device is working properly."
 
However, on my netbook it is displayed in My Computer.

Is there any way to access my external HDD on my laptop, other than through My Computer?
It is urgent that I can access it on my laptop and not only on my netbook
LVL 1
hermesalphaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MagicFarmerCommented:
Richt ciick on the My Computer icon in your start tree and choose the manage option. In the left hand pane choose inflate the storage container. Highlight the disk management option.  In the right hand pane you will see the different discs on your system.  Most likely your laptop has confused the dirve letter deisnations.  Highlight your HDD, right click and choose assign drive letter and path.  Choose a drive letter and your HDD should now be mapped properly.
0
mmarx82Commented:
Sounds like you might need to assign it a drive letter, you should only have to do this once.
1. Right Click on My Computer
2. Click on Manage
3. On the left side under Storage, Click on Disk Management
4. In the center screen at the top you will see all your system drives. At the bottom of the center look for a drive that is either sharing the same drive letter as another drive or one that hasn't been assigned a drive letter.
5. Right Click to on the right side of Disk X, where X matches the drive in step 4. (Will be the area that says whether or not the drive is Healthy
6. Click on "Change Drive Letter and Paths"
7. Click Change
8. In the drop down box give it a Drive letter your computer is not using.
9. Click OK
10. Click OK again
 Your drive should now be visible. This happens sometimes in the corporate world as well if you have Mapped Drives.
0
andeslauCommented:
another possible reason is you have network drive map e.g. e: or f:

e.g. if the disk management assigned your ext. HDD as F: but you have network drive F: mapped, you may need to disconnect the network drive first.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ydsonlineCommented:
I'd also suggest to try the following:
1. Plug the drive back into your netbook and click the "Safely Remove Hardware" and disconnect the drive.
2. Plug the drive into your Laptop.
3. Restart you Laptop and see if it will show up now.

0
ydsonlineCommented:
Also you may want to have a look at this article: http://www.bleepingcomputer.com/forums/topic189726.html

You're not the only one that have problems when running combofix.
Perhaps if none of the above suggestions work, do a system restore a day before running combofix. Combofix disabling autoplay should not have made a difference, but there might be other setting that may have caused an issue with your USB drive letter recognition.
0
hermesalphaAuthor Commented:
I changed drive letters for internal HDD to C: and D: and for DVD-drive to E: (before, DVD-drive had D: and internal HDD had E:). But there was nothing displayed about removable media, so in right-click My Computer/Managage my external HDD was not recognized.

But it is recognized in menu for Safely Remove Hardware, I can choose to remove it there.
0
hermesalphaAuthor Commented:
ydsonline,

It doesn't work with what you suggested, because earlier (before ComboFix) the main problem I already had with this external HDD was that immediately after booting up, I had to unplug and plug in again my external HDD and first after doing so it was recognized in My Computer.

But now, after ComboFix, it doesn't even work with unplug and plug in again, it does not get recognized in My Computer.

0
optomaCommented:
Strange
This is a long shot!
Microsoft Automated Troubleshooting Services:
http://support.microsoft.com/mats/?DiagID=100001&EulaAccept=Yes
0
webbster20Commented:
What format is the drive?

Did you go into disk management when you went into manager?
0
mmarx82Commented:
Did you make a backup of your registry before using combofix, I'm thinking it deleted some registry entries. If so restore your registry, don't use combofix but use Malwarebytes Anti-Malware (currently version 1.45) after the registry restore to remove the bad entries.
If not your looking at a doing a system restore or a fresh re-install of your computers OS.
0
hermesalphaAuthor Commented:
Device Manager/Universal Serial Bus Controllers: My external HDD is recognized here, and reports that it functions properly.

I've rid of a rootkit now and several malwares, and the laptop works fine (except for this last thing with the external HDD).

I've already used Malwarebytes Anti-Malware, and some other tools to remove the malware and rootkit  on my laptop.

My laptop is not connected to any network, but it's a personal laptop so the drive letters assigned should be alright now.

optoma, I'll try your link for Automated Troubleshoot Service now. I did the manual Troubleshooting, but couldn't resolve it that way.
0
hermesalphaAuthor Commented:
optoma,

When I tried to run the Automated Troubleshooting Service, I received this message:

"C:\Documents and Settings\My Name\My Documents\Mats_Run.dvd.exe is not a valid Win32 application."
0
hermesalphaAuthor Commented:
I disabled Eset Smart Security and Firewall but still get the message it's not a valid Win32 application
0
hermesalphaAuthor Commented:
http://www.sevenforums.com/performance-maintenance/7207-messed-up-external-hard-drive-icon.html

Do anyone of you think that if I delete the desktop.ini file from C:\WINDOWS\System32, this would resolve the problem (see the above link)?
0
optomaCommented:
Run Atf cleaner to clear temp files http://www.atribune.org/index.php?option=com_content&task=view&id=25&Itemid=25

Run this removal tool
ftp://ftp.f-secure.com/anti-virus/tools/f-bagle.exe

>No harm in trying what you linked above
0
hermesalphaAuthor Commented:
It actually worked fine after I deleted the desktop.ini file from C:\WINDOWS\System32, now my external HDD is accessible again in My Computer window (although the icon is the wrong icon like before: a white sheet of paper with a folded upper-right corner and inside/on this "sheet" is an icon). Shouldn't I be able to change this icon somewhere in Device Manager?

Although everything seems fine now (except for the odd icon for external HDD), can this desktop.ini file affect other applications in any negative way? Or is it totally safe to completely and permanently remove the desktop.ini file from System32?
0
ydsonlineCommented:
You could try this:

Open regedit and goto:

1. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer

2. Under this key, you'll see a key "DriveIcons". Delete it and log off or restart your Windows.

3. It'll solve the problem and you'll get back default drive icons in My Computer.

resource from: http://www.askvg.com/how-to-fix-corrupt-drive-icons-in-my-computer/
0
ydsonlineCommented:
If the above doesn't work, you can also look if an autorun file exist in the root of your external drive. Remove it temporarily if it does exist and see if that solves. If it does solve it then have a look a the entries inside the autorun file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hermesalphaAuthor Commented:
ydsonline,

in the key 'explorer' in regedit, I have these sub-keys:

(Default)
IconUnderline
Max Cached Icons

But there's no DriveIcons there. Should it have been?
0
hermesalphaAuthor Commented:
And there's no autorun-file in root-folder on my external HDD either
0
mmarx82Commented:
There is the autorun approch if you have an ico file: http://www.nirmaltv.com/2007/07/12/how-to-change-the-default-icon-for-removable-drives-2/
 
You can also try this, in the registry:
Navigate to: HKEY_CLASSES_ROOT\Drive\shell

And set the default value to "none."  
You may have to reboot afterword.

Capture2.JPG
0
hermesalphaAuthor Commented:
The shell in folder Drive was already set to 'none'.

I'll try later, when I find an icon, to use the autorun approach
0
ydsonlineCommented:
If the usb drive has an autorun.inf file, it's most likely hidden.
Go to Folder options under control panel, then the View Tab and tick "Show Hidden files and folders"
Also uncheck "hide unprotected operating system files"
Let us know...
0
hermesalphaAuthor Commented:
ydsonline,

I did as you instructed and checked 'Show hidden files and folders' and unchecked 'Hide unprotected operating system files'.

Then, on my external HDD, there was this autorun:

Autorun.inf (90 bytes)

Should I remove it temporarily?

0
mmarx82Commented:
Just rename it, remove your device and reconnect it. Alternitively you can open it and see if there is a line the specifies the ICON file that it is supposed to use.
0
hermesalphaAuthor Commented:
I run ComboFix a second time, and finally: my external HDD is both recognized and the icon is back at last!

It was the Autorun.inf file that was the one to blame: ComboFix deleted it on my external HDD, and then everything was back to normal
0
optomaCommented:
Good!
Hows all behaving now?
0
hermesalphaAuthor Commented:
Deleting the Autorun-file from external HDD solved the problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.